Support Forums

Error running command: Build script returned non-zero exit code: 127

HI, unfortunately I did not solve the issue as of now and got busy with other things. Sorry for being no help here.

hi @mujeebahmed10p - Sorry you are encountering this! I am not exactly sure what to suggest that I haven’t already except to reach out to the folks who made the package and see if they have any ideas as to what could be causing the problem. If they give you any useful info please do let us know. I wish I had more ideas - but i’m stumped.

Thank you for the follow-up to share what you discovered, @mujeebahmed10p. Closing the loop to share what you learned will hopeful provide benefit to someone else searching the community site for answers in the future.

We appreciate that you took the time to share your experience. It is amazingly helpful and not everyone loops back here when they find a solution! :+1:

1 Like

Thanks for helping out guys! I really appreciate it.

Got a tip from someone to run,

gatsby serve

(on local machine) and lo and behold I got a different error,
WebpackError: TypeError: Cannot set property 'vectorMap' of undefined

The issue is definitely not related to Netlify. It’s just that Gatsby isn’t able to use that package in it’s build process (probably need to add something to gatsby-config.js before it will start working).

Thanks bro…i got my problem solved

I struggled for 3 hours until I found your solution. :heart:

Worked! Thanks @jaylowe1

This worked for me with a create-react-app

  1. Go to settings

  2. Go to environments

3 Under the environment tab

  • add CI as key
  • & FALSE as Value