Error on deploying

So I tried deploying my code to the live website, it has never been a problem in the past but now I’ve been getting errors on deploying. See error log below:

Any advice?

11:19:58 AM: Build ready to start
11:20:00 AM: build-image version: 0582042f4fc261adc7bd8333f34884959c577302
11:20:00 AM: build-image tag: v3.7.6
11:20:00 AM: buildbot version: 3934dc3e65fec0466cd25051c676f6e727c64ab1
11:20:00 AM: Building without cache
11:20:00 AM: Starting to prepare the repo for build
11:20:01 AM: No cached dependencies found. Cloning fresh repo
11:20:01 AM: git clone GitHub - JO15on/Portfolio
11:20:04 AM: Preparing Git Reference refs/heads/master
11:20:05 AM: Parsing package.json dependencies
11:20:06 AM: Starting build script
11:20:06 AM: Installing dependencies
11:20:06 AM: Python version set to 2.7
11:20:07 AM: Downloading and installing node v14.15.5…
11:20:07 AM: Downloading https://nodejs.org/dist/v14.15.5/node-v14.15.5-linux-x64.tar.xz
11:20:08 AM: Computing checksum with sha256sum
11:20:08 AM: Checksums matched!
11:20:11 AM: Now using node v14.15.5 (npm v6.14.11)
11:20:11 AM: Started restoring cached build plugins
11:20:11 AM: Finished restoring cached build plugins
11:20:11 AM: Attempting ruby version 2.6.2, read from environment
11:20:12 AM: Using ruby version 2.6.2
11:20:13 AM: Using PHP version 5.6
11:20:13 AM: Started restoring cached node modules
11:20:13 AM: Finished restoring cached node modules
11:20:13 AM: Installing NPM modules using NPM version 6.14.11
11:20:50 AM: npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I’ll try to do my best with it!
11:20:50 AM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/babel-runtime/node_modules/core-js
11:20:50 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
11:20:50 AM: > core-js@3.6.4 postinstall /opt/build/repo/node_modules/core-js
11:20:50 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
11:20:50 AM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/karma/node_modules/core-js
11:20:50 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
11:20:51 AM: > @angular/cli@12.0.0 postinstall /opt/build/repo/node_modules/@angular/cli
11:20:51 AM: > node ./bin/postinstall/script.js
11:20:53 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.12 (node_modules/webpack-dev-server/node_modules/fsevents):
11:20:53 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
11:20:53 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.12 (node_modules/watchpack/node_modules/fsevents):
11:20:53 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
11:20:53 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.12 (node_modules/karma/node_modules/fsevents):
11:20:53 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
11:20:53 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):
11:20:53 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
11:20:53 AM: added 1616 packages from 1157 contributors and audited 1821 packages in 39.394s
11:20:54 AM: 59 packages are looking for funding
11:20:54 AM: run npm fund for details
11:20:54 AM: found 84 vulnerabilities (10 low, 56 moderate, 18 high)
11:20:54 AM: run npm audit fix to fix them, or npm audit for details
11:20:54 AM: NPM modules installed
11:20:54 AM: Started restoring cached go cache
11:20:54 AM: Finished restoring cached go cache
11:20:54 AM: Installing Go version 1.12
11:21:01 AM: unset GOOS;
11:21:01 AM: unset GOARCH;
11:21:01 AM: export GOROOT=’/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64’;
11:21:01 AM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64/bin:${PATH}";
11:21:01 AM: go version >&2;
11:21:01 AM: export GIMME_ENV="/opt/buildhome/.gimme_cache/env/go1.12.linux.amd64.env"
11:21:01 AM: go version go1.12 linux/amd64
11:21:01 AM: Installing missing commands
11:21:01 AM: Verify run directory
11:21:03 AM: ​
11:21:03 AM: ────────────────────────────────────────────────────────────────
11:21:03 AM: Netlify Build
11:21:03 AM: ────────────────────────────────────────────────────────────────
11:21:03 AM: ​
11:21:03 AM: ❯ Version
11:21:03 AM: @netlify/build 11.17.0
11:21:03 AM: ​
11:21:03 AM: ❯ Flags
11:21:03 AM: deployId: 60a2899e2d716f00b4e98b6a
11:21:03 AM: ​
11:21:03 AM: ❯ Current directory
11:21:03 AM: /opt/build/repo
11:21:03 AM: ​
11:21:03 AM: ❯ Config file
11:21:03 AM: No config file was defined: using default values.
11:21:03 AM: ​
11:21:03 AM: ❯ Context
11:21:03 AM: production
11:21:03 AM: ​
11:21:03 AM: ────────────────────────────────────────────────────────────────
11:21:03 AM: 1. Build command from Netlify app
11:21:03 AM: ────────────────────────────────────────────────────────────────
11:21:03 AM: ​
11:21:03 AM: $ ng build
11:21:06 AM: ​
11:21:06 AM: ────────────────────────────────────────────────────────────────
11:21:06 AM: “build.command” failed
11:21:06 AM: ────────────────────────────────────────────────────────────────
11:21:06 AM: ​
11:21:06 AM: Error message
11:21:06 AM: Command failed with exit code 3: ng build
11:21:06 AM: ​
11:21:06 AM: Error location
11:21:06 AM: In Build command from Netlify app:
11:21:06 AM: ng build
11:21:06 AM: ​
11:21:06 AM: Resolved config
11:21:06 AM: build:
11:21:06 AM: command: ng build
11:21:06 AM: commandOrigin: ui
11:21:06 AM: environment:
11:21:06 AM: - NODE_VERSION
11:21:06 AM: publish: /opt/build/repo/dist/Jon-Portfolio
11:21:07 AM: Caching artifacts
11:21:07 AM: Started saving node modules
11:21:07 AM: Finished saving node modules
11:21:07 AM: Started saving build plugins
11:21:07 AM: Finished saving build plugins
11:21:07 AM: Started saving pip cache
11:21:07 AM: Finished saving pip cache
11:21:07 AM: Started saving emacs cask dependencies
11:21:07 AM: Finished saving emacs cask dependencies
11:21:07 AM: Started saving maven dependencies
11:21:07 AM: Finished saving maven dependencies
11:21:07 AM: Started saving boot dependencies
11:21:07 AM: Finished saving boot dependencies
11:21:07 AM: Started saving rust rustup cache
11:21:07 AM: Finished saving rust rustup cache
11:21:07 AM: Started saving go dependencies
11:21:09 AM: Finished saving go dependencies
11:21:12 AM: Build failed due to a user error: Build script returned non-zero exit code: 2
11:21:12 AM: Creating deploy upload records
11:21:12 AM: Failing build: Failed to build site
11:21:12 AM: Failed during stage ‘building site’: Build script returned non-zero exit code: 2
11:21:12 AM: Finished processing build request in 1m11.772044232s

Hi there!

Sorry to hear you are encountering issues. My first suggestion would be checking out these two support guides, as they may get you on the right path!

If you read through these are still aren’t having any luck, please share your Netlify site name and your repo so that we can look into this further.