Error: module "KeepIt" not found; either add it as a Hugo Module or store it in "/opt/build/repo/themes".: module does not exist

Site name: gracious-perlman-b5acef
Using hugo

Hi, I’m attempting to help a friend out with running a hugo site so ive cloned her repo. GitHub - tacokitan/site to https://github.com/sarahgguwu/site

When I try and build the site using hugo I get an error: The full build log is below, when cloned and built locally it works fine.

5:30:19 AM: Build ready to start
5:30:20 AM: build-image version: d84c79427e8f83c1ba17bcdd7b3fe38059376b68
5:30:20 AM: build-image tag: v3.6.1
5:30:20 AM: buildbot version: 84797942a921f1c638bb743029b0d17c8e0112bd
5:30:20 AM: Fetching cached dependencies
5:30:21 AM: Failed to fetch cache, continuing with build
5:30:21 AM: Starting to prepare the repo for build
5:30:21 AM: No cached dependencies found. Cloning fresh repo
5:30:21 AM: git clone https://github.com/sarahgguwu/site
5:30:22 AM: Preparing Git Reference refs/heads/main
5:30:23 AM: Starting build script
5:30:23 AM: Installing dependencies
5:30:23 AM: Python version set to 2.7
5:30:25 AM: v12.18.0 is already installed.
5:30:25 AM: Now using node v12.18.0 (npm v6.14.4)
5:30:26 AM: Started restoring cached build plugins
5:30:26 AM: Finished restoring cached build plugins
5:30:26 AM: Attempting ruby version 2.7.1, read from environment
5:30:27 AM: Using ruby version 2.7.1
5:30:27 AM: Using PHP version 5.6
5:30:27 AM: Installing Hugo 0.81.0
5:30:28 AM: hugo v0.81.0-59D15C97+extended linux/amd64 BuildDate=2021-02-19T17:07:12Z VendorInfo=gohugoio
5:30:28 AM: Started restoring cached go cache
5:30:28 AM: Finished restoring cached go cache
5:30:28 AM: go version go1.14.4 linux/amd64
5:30:28 AM: go version go1.14.4 linux/amd64
5:30:28 AM: Installing missing commands
5:30:28 AM: Verify run directory
5:30:30 AM: ​
5:30:30 AM: ────────────────────────────────────────────────────────────────
5:30:30 AM:   Netlify Build                                                 
5:30:30 AM: ────────────────────────────────────────────────────────────────
5:30:30 AM: ​
5:30:30 AM: ❯ Version
5:30:30 AM:   @netlify/build 9.8.3
5:30:30 AM: ​
5:30:30 AM: ❯ Flags
5:30:30 AM:   deployId: 60474e3bf067e30008cd12c9
5:30:30 AM:   mode: buildbot
5:30:30 AM: ​
5:30:30 AM: ❯ Current directory
5:30:30 AM:   /opt/build/repo
5:30:30 AM: ​
5:30:30 AM: ❯ Config file
5:30:30 AM:   /opt/build/repo/netlify.toml
5:30:30 AM: ​
5:30:30 AM: ❯ Context
5:30:30 AM:   production
5:30:30 AM: ​
5:30:30 AM: ────────────────────────────────────────────────────────────────
5:30:30 AM:   1. build.command from netlify.toml                            
5:30:30 AM: ────────────────────────────────────────────────────────────────
5:30:30 AM: ​
5:30:30 AM: $ hugo
5:30:30 AM: Total in 1 ms
5:30:30 AM: Error: module "KeepIt" not found; either add it as a Hugo Module or store it in "/opt/build/repo/themes".: module does not exist
5:30:30 AM: ​
5:30:30 AM: ────────────────────────────────────────────────────────────────
5:30:30 AM:   "build.command" failed                                        
5:30:30 AM: ────────────────────────────────────────────────────────────────
5:30:30 AM: ​
5:30:30 AM:   Error message
5:30:30 AM:   Command failed with exit code 255: hugo
5:30:30 AM: ​
5:30:30 AM:   Error location
5:30:30 AM:   In build.command from netlify.toml:
5:30:30 AM:   hugo
5:30:30 AM: ​
5:30:30 AM:   Resolved config
5:30:30 AM:   build:
5:30:30 AM:     command: hugo
5:30:30 AM:     commandOrigin: config
5:30:30 AM:     environment:
5:30:30 AM:       - HUGO_VERSION
5:30:30 AM:       - HUGO_ENABLEGITINFO
5:30:30 AM:       - HUGO_ENV
5:30:30 AM:     publish: /opt/build/repo/public
5:30:31 AM: Caching artifacts
5:30:31 AM: Started saving build plugins
5:30:31 AM: Finished saving build plugins
5:30:31 AM: Started saving pip cache
5:30:31 AM: Finished saving pip cache
5:30:31 AM: Started saving emacs cask dependencies
5:30:31 AM: Finished saving emacs cask dependencies
5:30:31 AM: Started saving maven dependencies
5:30:31 AM: Finished saving maven dependencies
5:30:31 AM: Started saving boot dependencies
5:30:31 AM: Finished saving boot dependencies
5:30:31 AM: Started saving rust rustup cache
5:30:31 AM: Finished saving rust rustup cache
5:30:31 AM: Started saving go dependencies
5:30:31 AM: Finished saving go dependencies
5:30:33 AM: Build failed due to a user error: Build script returned non-zero exit code: 2
5:30:33 AM: Failing build: Failed to build site
5:30:33 AM: Failed during stage 'building site': Build script returned non-zero exit code: 2
5:30:33 AM: Finished processing build request in 12.975205562s

We’ve tried setting a themesDir in config.toml but to no avail, other support threads regarding the same issue don’t seem to help (or I’m just doing something wrong)

I am going to assume it’s the case that’s making the difference. You’ve named the folder keepit but calling it using KeepIt. Try keeping the case same.

1 Like