Error loading cloudinary as external media library

Hello!
I’m trying to allow multiple image selection in the Netlify CMS on a Gatsby site. I keep getting this error although it appears I have all of the config files set up correctly:

Error loading the CMS configuration
Config Errors:
Error: Missing external media library ‘cloudinary’. Please use ‘registerMediaLibrary’ to register it.
Check your config.yml file.

Relevant packages in package.json:

    "netlify-cms-app": "^2.15.63",
    "netlify-cms-media-library-cloudinary": "^1.3.10",
    "gatsby-plugin-netlify-cms": "^6.5.0",

Gatsby config:

{
      resolve: "gatsby-plugin-netlify-cms",
      options: {
        modulePath: `${__dirname}/src/netlifycms/cms.js`,
        manualInit: true,
      },
    }
static/admin/config.yml:

/static/admin/config.yml

backend:
  name: git-gateway
  repo: user/repo
  branch: main

media_library:
  name: cloudinary
  config:
    cloud_name: xxxxxxxx #real name removed
    api_key: 1111111111111111 #real key removed

media_folder: "images/uploads" # Media files will be stored in the repo under images/uploads

collections:
  - name: "item" # Used in routes, e.g., /admin/collections/blog
    label: "item" # Used in the UI
    folder: "content/items" # The path to the folder where the documents are stored
    create: true # Allow users to create new documents in this collection
    slug: "{{slug}}" # Filename template, e.g., YYYY-MM-DD-title.md
    fields: # The fields for each document, usually in front matter
      - { label: "Title", name: "title", widget: "string" }
      - { label: "Publish Date", name: "date", widget: "datetime" }
      - {
          label: "Featured Image",
          name: "thumbnail",
          widget: "image",
          allow_multiple: true,
          media_library: { name: cloudinary, output_filename_only: true },
        }
      - { label: "Body", name: "body", widget: "markdown" }

/src/netlifycms/cms.js

import CMS from "netlify-cms-app";
import cloudinary from "netlify-cms-media-library-cloudinary";

CMS.init();
CMS.registerMediaLibrary(cloudinary);

The error occurs regardless of if user is logged in to cloudinary account. I have tried with and without the manualInit setting in the gatsby config and cms.js and tried changing a lot of minor things but I’m having no luck, just continuing to get the aforementioned error when I go to site.com/admin/

Any ideas or glaringly obvious omissions on my part?

Thanks for the help!

Hi there! Thanks for your interest in Netlify CMS. Looks like you posted your question a little while ago, but that you haven’t received a solution yet. Here’s where you might get more help:

netlifycms.org - the site houses our extensive documentation that likely contains helpful information to get you back on track.

netlify cms slack - join our friendly slack channel and chat with other cms pros to get the help you need.

GitHub Issues - think you’ve found a bug, or would like to make a feature request? Make your voice heard here. Netlify CMS is open source - PRs and other contributions are also welcome!

Stack Overflow Check StackOverflow for questions tagged “Netlify CMS” if you don’t get an answer in the Slack or the GH issues. StackOverflow reaches a worldwide audience of knowledgeable people.

Your question will be left open here for anyone to comment - but we encourage you to check out the above resources if you are still looking for a solution!