Support Forums

Error "DNS verification failed, domain doesn't appear to be served by Netlify"

Fair shout, though I’ve checked them a few times. Currently:


Good instinct from @gregraven but you had all of that configured correctly, and indeed, nothing you did seems incorrect. Instead, something went wrong with our automagic configuration for the jump.run hostnames: I see we had no DNS “A” record for plain “jump.run” at our DNS service! I got that in place and now the DNS warning is gone, and I think the SSL certificate will arrive shortly.

1 Like

SSL Looks good now. Thanks for the help @fool & @gregraven, on a Sunday no less! :clap::pray:

This is why you get the Big Bucks.

1 Like

I get the same error message. However, I bought my domain through Netlify to avoid any issues. Any ideas on how to fix this?

@cschweipert Welcome. Any idea what your domain name is? The more pertinent information you share, the easier it is for others to help you.

Sorry, yes!

Default domain: https://cocky-noyce-1b948d.netlify.app

Custom domain: christinaschweipert.tech

@cschweipert Your custom domain is set up with Netlify, but your A record seems to point to Amazon. If your custom domain settings in Netlify are correct, you might try deleting everything and starting over, unless someone from support has a better idea.

@gregraven Thank you for taking the time to check this. I deleted the custom domain and added it again and it works!!

1 Like

Hello, I am facing the exact same issue. I have been using bamboocreativestudio.com on your website for over a year now without any issues. I recently moved the domain to a different Netlify and now it is having issues with the SSL certificate.
I now get “bamboocreativestudio.com doesn’t appear to be served by Netlify”
How should I proceed to fix this issue?
Thank you


In response to edehlouz, I did a quick check on your NS records and you have NS records ns36.domaincontrol.com and ns35.domaincontrol.com which I’m not sure should be there.

@edehlouz Welcome to the Netlify community. Does the docs help?

Currently, you have a very odd DNS set up, with a combination of two different DNS sources. You would be better off picking either:

  1. domaincontrol.com (GoDaddy) with the A record pointing at Netlify’s new load balancer IP address and a CN1. AME pointing at your Netlify subdomain, OR

  2. delegating DNS to Netlify.

Right now, you seem to have both.

Hello @gregrave. Thank you for your help. The reason I have two different NS is because my email is linked to godaddy’s servers so if I deligate the DNS to netlify, my mail stops working.

How would I go about the first option?

Just follow the directions in the documentation

Hey guys,

I’m having a similar dns issue. I think I might have deleted the dns record for my primary domain (the one starting with “www”). If I were to re-add in that record, what would I fill in the fields with? e.g. record type, name value (ip) (I have checked the documentation but am a bit lost. I purchased my domain through porkbun). The dns record for my redirect domain (the one without ‘www’) still exists and I think was generated by netlify when I connected my purchased domain

My error msg: There’s a Netlify DNS zone for this domain, but no DNS records associated with it.

Any help would be great thanks!

@samsaga1307 What is your custom domain name?

Heya, it’s samsaga.design

Hi, @samsaga1307. I think you deleted the NETLIFY type DNS record for the www subdomain here:


Is that correct? If so, the easiest way to recreate it is to remove the custom domain from the site and then add it back again. You would do this under the site settings found at Site Name > Settings > Domain management > Custom domains.

If that doesn’t work or if there are any questions, please let us know.


Hey Luke, thank you so much! That’s seems to have solved it :smile:

1 Like

Hi there, @Tee1 :wave:

I see you have posted in five threads about the same topic. Please refrain from opening multiple threads with the same question. I assure you, we will assist you as soon as we are able to. I have looped in our Support Engineers, and a member of our team will follow up on this thread once they dive in further.