Error DNS_PROBE_FINISHED_NXDOMAIN for Namecheap domain

Hi…

My netlify site : https://angry-bhabha-ea2e97.netlify.app/
Custom domain : sarcastechie.dev

Query : I’m getting “DNS_PROBE_FINISHED_NXDOMAIN” on my custom domain while the netlify site works fine. I am using ThanosJS template for now just to check and it is successfully published.

I bought this custom domain from Namecheap, and recently I’ve added this domain to Netlify by adding nameservers in Namecheap domain settings.

Why do I get this error with the custom domain?

@Hitesh_Abichandani Welcome to the Netlify community. For future reference, there is a search feature on this forum, and searching for your error reveals many, many posts where this has been discussed by others.

You seem to have an inactive DNS zone.

|================== check for inactive DNS zone =================
| --------------- last line should show nsone.net ---------------
| ----------------- for sites using Netlify DNS -----------------
| ---------------- otherwise will show DNS source ---------------
| ---------------------- sarcastechie.dev ----------------------
.			34720	IN	NS	l.root-servers.net.
.			34720	IN	RRSIG	NS 8 0 518400 20210605170000 20210523160000 14631 . kC8t28xiz85dgsHZMfh/oM7JF18nzB0qHaOXrC7UJIjIYDSTGIc0XPMv cg53e/PryETpPhL9GVr8DBZF8+VdQKCZKlZyNyF4Cdb1jcDebBUlp9xe RhagjGqaKwDW1xu0VHfSdNOpNEKgl9/70SeJrbMrJcKA/UCMr137/JNP dVWNjLaZRIACmiz6djQe7bq1hedplpNHedu7UrfiWyyF2ecYpQ+R2JEa R/mybfWIt5AEdKsEY8XG3d90WnJMh+uHcgFOuKxQ12KHGip03g8EyeUL a1+ikzDaFOa5XAexUViTEHvZL+Z3rp43udkdCRa7LV4tOGdpE/N3XyOq /73ekw==
;; Received 525 bytes from 192.168.1.1#53(192.168.1.1) in 18 ms

;; Received 45 bytes from 198.97.190.53#53(h.root-servers.net) in 177 ms
|================================================================

See the documentation here:

The solution is either a) activate the inactive zone or b) delete the inactive zone.

1 Like

In the article shared by you, it says “SSL certificate provisioning failures are the most common issues inactive DNS zones cause.”

I already have an SSL certificate provided by Namecheap from where I bought the domain. But in Netlify settings I could see this,
image

I’m sure this is the issue. But I tried to add my own certificate in Netlify, it says “certificate is not a valid PEM certificate”.

[Edit] : I tried refering to the topic “Certificate is not a valid PEM certificate” but still no luck. However this answer is really close to my situation.

Hi… I just checked and the issue is resolved. I think it was the Time To Live. I should’ve waited. Sorry for the trouble. :sweat: