Error babel-plugin-remove-graphql-queries - Faild during stage building

Hello everyone,
I get again a non-exit code: 1.

Link of the full deployment: Netlify App

[…]

1:00:52 PM: Python version set to 2.7

1:00:52 PM: Started restoring cached node version

1:00:55 PM: Finished restoring cached node version

1:00:55 PM: v12.18.0 is already installed.

1:00:56 PM: Now using node v12.18.0 (npm v6.14.4)

1:00:56 PM: Started restoring cached build plugins

1:00:56 PM: Finished restoring cached build plugins

1:00:56 PM: Attempting ruby version 2.7.1, read from environment

1:00:57 PM: Started restoring cached ruby version

1:00:57 PM: Finished restoring cached ruby version

1:00:59 PM: Using ruby version 2.7.1

1:00:59 PM: Using PHP version 5.6

1:00:59 PM: Started restoring cached yarn cache

1:01:06 PM: Finished restoring cached yarn cache

1:01:07 PM: No yarn workspaces detected

1:01:07 PM: Started restoring cached node modules

1:01:07 PM: Finished restoring cached node modules

1:01:07 PM: Installing NPM modules using Yarn version 1.22.4

1:01:07 PM: yarn install v1.22.4

1:01:07 PM: [1/4] Resolving packages…

1:01:08 PM: [2/4] Fetching packages…

1:01:11 PM: error babel-plugin-remove-graphql-queries@4.10.0: The engine “node” is incompatible with this module. Expected version “>=14.15.0”. Got "12.18.0"

#####################
What is this? How can I upgrade this?

I did successfully: yarn add babel-plugin-remove-graphql-queries

“dependencies”: {
“babel-plugin-remove-graphql-queries”: {
“version”: “3.14.0”,
“resolved”: “https://registry.npmjs.org/babel-plugin-remove-graphql-queries/-/babel-plugin-remove-graphql-queries-3.14.0.tgz”,
“integrity”: “sha512-uRqbsHOcJ1kWn6IK6clZOGHBnQCddiz1LuoGIpv/hcGZCO1nCy16z9KMgEM8TdGG6L6cO31mNr1RcVmvGtcCEw==”,
“requires”: {
@babel/runtime”: “^7.15.4”,
“gatsby-core-utils”: “^2.14.0”
}
}
}

#####################

1:01:11 PM: error Found incompatible module.

1:01:11 PM: info Visit yarn install | Yarn for documentation about this command.

1:01:11 PM: Error during Yarn install

[…]

How can this error be solved?
Looking really forward to any answers.

SOLVED

I set the key to “NODE_VERSION” and the value to the current node version: 16.14.2

Source:

Thanks for coming back and sharing your solution, @Samu! glad you got this working.

Happy building :rocket: