Domain Purchase Timed Out, Domain No Longer Working Properly

Hi, guys!

I’m having a problem with purchasing and using a new domain at

I first tried to purchase the domain here on Netlify Domains and received a timeout error. I was never charged and, from what I can tell, I don’t own the domain through Netlify. However, the domain did show up on the new site that I created named I deleted the domain hoping that the custom domain would propagate out and end up being removed.

I have since purchased my custom domain via Google Domains so I do now know that I own it. However, I am currently getting an error when I try to add the custom domain to Netlify DNS that says:

"A DNS zone for this domain already exists on NS1

It appears this domain is already managed by our DNS provider, perhaps via another service. You can manage your domain via the external service that also uses NS1 as DNS provider"

However, I know that this isn’t true because the domain in the Google Domains is currently hooked up to the default Google nameservers. Additionally, when I try to visit the domain, it is unreachable.

To me, it is looking like, despite the timeout error when I originally tried to buy the domain, Netlify DNS thinks this domain was purchased through Netlify Domains and was auto-setup for it’s DNS here on Netlify. However, it errored out and I was never charged so now I do have it on Google Domains (and not hooked up to Netlify DNS yet.)

Hoping for some guidance (or that the error propagates out and disappears)!

Hi, @anthonyshew, I did find a DNS zone for which should not have existed under our NS1 account but did.

You should be able to create the DNS zone at Netlify for this custom domain now. If not, please reply here anytime.

Awesome! I just went through the process again and everything worked as expected. Thank you!

1 Like