Domain is intermittently accessible

Hi gang,
my site: rjdusk.netlify.app under the custom domain: www.madebydusk.com is intermittently accessible. This only came about today after changing the nameservers within my domain registrars control panel to use Netlify’s nameservers:

    dns1.p03.nsone.net
    dns2.p03.nsone.net
    dns3.p03.nsone.net
    dns4.p03.nsone.net  

Any ideas of what’s going down? No doubt the problem lays between the keyboard and the brain :slight_smile:

It doesn’t seem like the DNS is correctly configured, or if it is, it has not propagated:

Curious, it’s most likely got to be a propagation issue. I’ll include some screenshots from my end:

Registrar CP & Netlify:

That’s all I’ve set, pointing my domain to Netlify’s nameservers, then configured the DNS settings within Netlify… is my understanding correct? Thanks!

Yes, your understanding and setup looks correct to me. How long as it been since you made this change?

About 6 hours ago now… should I hold tight for a while longer? Maybe give it 24 hours?

Well, in most cases it doesn’t really take that long even though it’s recommended to wait for 24 hours. I myself am not sure why this is happening. I just checked using another tool and here are the results:

Seems like it’s not working everywhere, especially on Google DNS, which I suppose is a pretty common public DNS.

How weird, this is sounding more like something to take up with my domain registrar?

Probably yes, however just waiting it out might fix it automatically too.

You may want to set the second to not be dns registered that will probably be causing the issue.

Sorry how do you mean?

Hi, @rjdusk. DNS lookups are failing because DNSSEC is enabled for the domain but Netlify DNS doesn’t support DNSSEC.

You can see the errors here:

https://dnsviz.net/d/madebydusk.com/dnssec/

The solutions for this are either to A) disable DNSSEC for the domain or B) to stop using Netlify DNS (and use the external DNS instructions instead).

If there are other questions or concerns, please let us know.

Great thanks, I’ll remove DNSSEC and see how I go