Home
Support Forums

DNS zone not updating

Hi, I’ve added 2 domains lately from GoDaddy “ewn-sa.com” and “ewn-bd.com”. I tried configuring ewn-bd.com as the custom domain for my site “ewn-ksa.netlify.app”, which worked just fine. However, I intend to use “ewn-sa” as my primary custom domain for the site. So, I removed “ewn-bd” from the site and added “ewn-sa” as the custom domain for the site. Although, I’ve done the same configuration as I did for the “ewn-bd” domain. Which is adding the 4 nameserver records in Godaddy DNS management.
However, nothing is working. :“http://ewn-sa.com” still redirects to GoDaddy and :“https://ewn-sa.com” fails to connect anywhere. I tried digging for DNS configuration error with “Google admin toolbox” and found that the cname record is missing. Not sure if it has anything to do with the issue. Please help.

Hi @Ishtiakmokut

I believe you are experiencing localised DNS caching.

You are using Netlify DNS, so you do not need to add CNAME records. Your DNS should look like this