Dns updating issue. trying to add A record from webflow

I keep getting the following error whenever I tried to add an A record from webflow

“dns_api tryapprio.com - tryapprio.com/A: 400 - link exists, all config must be empty”

Hello,

Can we please get some support on this as we are trying to launch our website today? Thank you!

hi there, we have flipped a switch that allows you to edit, delete, and add new ones of those records now. Thanks for your patience.

Hi @perry thank you for the update. What records are we showing currently for the site that we can remove? We seem to still be getting the error when we try adding the record but don’t know which record to remove that is conflicting right now

hi there, you will need to remove the A record before trying to set a new one - is this something you have already tried?

@perry -

are we supposed to remove all of these records?

those are the A records for the subdomains. Are you trying to point the subdomains somewhere else? If yes, then yes! If you are trying to only administer the apex domain tryapprio.com then those records you indicated should be left alone.

Can you explain in a different way what you trying to do? maybe then i can offer better asssitance :slight_smile:

@perry Perry, thank you for your patience. Here’s what we are trying to do:

  1. we have an existing website at tryapprio.com that we are trying to replace with a new website. The new website files are hosted on webflow so we want to point our existing domain using this new website and turn off the webflow custom domain!
  2. the new website that we want to push is hosted on webflow with the following configuration shown below

What’s the best option for removing the current site hosted in netlify and update it with the new site hosted on webflow (a records)?

great, thanks for explaining! I am actually going to ask my colleague Luke to step in and help you when he comes on shift in a few hours, as his knowledge of DNS is much deeper than mine. I wouldn’t want to delay you any further by giving you the wrong instructions. I am sure we can get this figured out.

@perry - thank you. I’ll wait until Luke gets online in a few hours for instructions!

@perry - i think i might’ve found the existing records that point to the current website that we may need to delete before adding the new records. can you confirm below?

@perry - we should be good to go on this issue. Thank you for all of your help!

Hi, @admins_fundra. Thank you for letting us know this is resolved. About the NETLIFY type records, there is more information here:

To summarize, the NETLIFY type records do need to be deleted before a different DNS record can be used for the same name (for certain record types).

I’ve unlocked all the existing records for this DNS zone now as well. ​Please let us know if there are any other questions about this.

1 Like