Home
Support Forums

DNS subdomain setup results in Not Found - Request ID

My netlify site: https://wishtenderblog.netlify.app/

My domain: wishtender.com, subdomain of interest blog.wishtender.com.

I believe the registrar is godaddy and I have the DNS set up on Netlify.

Some notes on my confusion on DNS:

I say “I believe” because I’m a little confused about the terms DNS and registrar and if these can differ between the domain and subdomain. But to give more of a picture, if I go to my godaddy it says for wishtender.com “We can’t display your DNS information because your nameservers aren’t managed by us.” And I can see wishtender.com in my Netlify domains. And I remember setting this up a few months ago, I’m just not sure about the terms DNS and registrar. And I only set this up for wishtender.com and maybe staging.wishtender.com- I’m confused if I have to do something else on godaddy to have Netlify control the DNS for blog.wishtender.com. Was making Netlify the DNS manager for wishtender.com enough or are there more steps to take on godaddy?

My issue

I’m trying to setup a subdomain- blog.wishtender.com to point to https://wishtenderblog.netlify.app/.

So I went into DNS records on Netlify for wishtender.com and created a CNAME record following this doc.

Name: blog.wishtender.com
TTL: 3600 seconds (defaulted)
Type: CNAME
Value: wishtenderblog.netlify.app

When I navigate to blog.wishtender.com, I expect it to forward to wishtenderblog.netlify.app but instead I get:

Not Found - Request ID: 01FJWSVB6AMEFCXNZFTZM44JGN.

The ID changes every time.

Hi @dashbarkhuss

You’re correct, the registrar is GoDaddy. Registrar being the service you use to register a domain. DNS on the other hand is the global system used to translate domain names, into the numbers assigned to servers around the world where the domain content is served from. In the case of Netlify, that uses a CDN, depending on the location you or any other visitor is in, these numbers will change so the content is served from the closest location. DNS is often handled by the registrar too.

I can see wishtender.com is configured to use Netlify DNS as seen below

% dig wishtender.com NS
;; ANSWER SECTION:
wishtender.com.		3600	IN	NS	dns2.p02.nsone.net.
wishtender.com.		3600	IN	NS	dns3.p02.nsone.net.
wishtender.com.		3600	IN	NS	dns4.p02.nsone.net.
wishtender.com.		3600	IN	NS	dns1.p02.nsone.net.

As such, you do not need a CNAME record. If using external DNS (e.g. with GoDaddy) you would configure blog.wishtender.com as per the documentation you referenced.

Instead try the following

  1. Remove this CNAME entry.
  2. Under https://app.netlify.com/sites/wishtenderblog/settings/domain add blog.wishtender.com as the custom domain.
  3. Navigate to https://app.netlify.com/teams/<YOUR_TEAM_NAME>/dns/wishtender.com and you should see the blog.wishtender.com`

Here is a setup I have

Custom domain

Domains

I originally tried this and it didn’t work which was why I tried the other way. After deleting the CNAME record, when I add blog.wishtender.com on https://app.netlify.com/sites/wishtenderblog/settings/domain I get:

wishtender.com is already registered. If you registered this domain name through a different registrar, select Add domain to begin delegating it to Netlify.

Can you take a screenshot of this please?

Thanks @dashbarkhuss,

This is because you already have wishtender.com in Netlify DNS.

Go ahead and click Add domain. The rest should sort itself out without issue.

1 Like