Home
Support Forums

DNS Records Not Resolving and Subdomain Broken

Netlify Site Name: musing-wiles-6f40ba.netlify.app
Desired Domain: claramarshall.com - domain registered with Hostpapa

DNS Issue is saying www.claramarshall.com doesn’t appear to be served by Netlify

I see nothing when I go to my custom domain but the netlify domain works. It has been 20 hours since I changed the DNS over and nothing is working.
I also setup an A record for a subdomain to point to my Hostpapa file manager at an IP and it is not resolving either.

The nameservers seems to be working properly so not sure why it is erroring for me
https://dnschecker.org/#NS/claramarshall.com

The subdomain seems to be pointing to the IP properly as well but not working for me
https://dnschecker.org/#A/wordpress.claramarshall.com

Please help was hoping to launch this tonight and have been on my hosting support the past 2 days struggling to get this working.

Hi there! We’ve created this DNS Quickstart guide for this very purpose - to get you up and running as quickly as possible.

Please take a look - we have many resources listed at the bottom, too. And, there are tons of DNS questions you can access through our search! If your problem still persists after reading through all relevant guides, please post again and we will troubleshoot with you.

Hey I already spent about 3-4 hours today reading through other support docs that seem relevant like this one from yesterday dns-records-not-resolving-even-way-after-ttl and going through the documentation.

I came here as my last resort after attempting this setup for the first time 5-6 days ago, then attempting to host the apex domain on Hostpapa 2 days ago, then it was failing and their support suggested the best way is to go back on Netlify in the end.

So I have read through all the DNS documentation and am still stuck.

cool, thanks for confirming. I can see your site perfectly, can you verify that you still can’t see it in an incognito window?

Yeah for me it is still broken. Tried clearing cache and flushing DNS with the google tool and still see old site.

Does the wordpress subdomain work for you? wordpress.claramarshall.com

are you able to see the apex domain if you try from a different network, i.e your phone?

Oh wow my cellular data worked. Oh man :man_facepalming:

Doesn’t rlly help me to get my site working since I am doing final bug tests and so my final URL is needed for my gatsby builds to get my site data

I should be seeing my Wordpress site on the subdomain though, would this be an issue on their end? and am still getting this error in Netlify

Hi, @claramarshall. I’m showing the apex domain, the www subdomain, and the wordpress subdomain all working when I test.

If they are not working for you, the following details will be helpful:

  • What public IP address is being used for DNS resolution?
  • What is returned by that IP address when the DNS queries for the custom domains above (apex, www subdomain, and wordpress subdomain)?

Personally, I think the best tool for troubleshooting DNS issues is dig. If it is possible to install this on your local system (for example with brew install dig on MacOS), I would highly recommend using it to troubleshoot.

If you have dig installed the output of the +trace version of the DNS lookup would be helpful. Here is a working example below.

Note, the text below isn’t helpful because it is my working lookup but it gives you an idea of what a successful traced lookup will look like:

$ dig +trace claramarshall.com

; <<>> DiG 9.10.6 <<>> +trace claramarshall.com
;; global options: +cmd
.			84753	IN	NS	a.root-servers.net.
.			84753	IN	NS	b.root-servers.net.
.			84753	IN	NS	c.root-servers.net.
.			84753	IN	NS	d.root-servers.net.
.			84753	IN	NS	e.root-servers.net.
.			84753	IN	NS	f.root-servers.net.
.			84753	IN	NS	g.root-servers.net.
.			84753	IN	NS	h.root-servers.net.
.			84753	IN	NS	i.root-servers.net.
.			84753	IN	NS	j.root-servers.net.
.			84753	IN	NS	k.root-servers.net.
.			84753	IN	NS	l.root-servers.net.
.			84753	IN	NS	m.root-servers.net.
.			84753	IN	RRSIG	NS 8 0 518400 20210117050000 20210104040000 42351 . Cimf/9hy+TM/6Fi3oTcQEbqyfxRL1Vs6UHZk2wr8LHzsEGwISvQBdHFR MlLJo5UOLjNDcPJY+ayCnXRjE17yykRKvvmI7ZCeEDyO17saAmVFOLTf 7XgLXkThdF2bbQxtCwwqdCkwMi3YilBRhAcyqRfplEXqmktAeA7fmwSW wLo4b4hOqnX2edNi4bNbWEZL7qbGnp65QwmxlKXXYkEJHOnlbmUrcpaR fSVxHk86wC1NatykwwOFqCcVXEO8DFzRqhsVGzc3GdZg/44WkvLAnzi8 iMfGJHQBFrkkJtOqrDsh9Nbw5Ii2PkKWAixZSdBUsOWBnQ4fJBk9eo3D O4MGcg==
;; Received 525 bytes from 8.8.8.8#53(8.8.8.8) in 18 ms

com.			172800	IN	NS	l.gtld-servers.net.
com.			172800	IN	NS	b.gtld-servers.net.
com.			172800	IN	NS	c.gtld-servers.net.
com.			172800	IN	NS	d.gtld-servers.net.
com.			172800	IN	NS	e.gtld-servers.net.
com.			172800	IN	NS	f.gtld-servers.net.
com.			172800	IN	NS	g.gtld-servers.net.
com.			172800	IN	NS	a.gtld-servers.net.
com.			172800	IN	NS	h.gtld-servers.net.
com.			172800	IN	NS	i.gtld-servers.net.
com.			172800	IN	NS	j.gtld-servers.net.
com.			172800	IN	NS	k.gtld-servers.net.
com.			172800	IN	NS	m.gtld-servers.net.
com.			86400	IN	DS	30909 8 2 E2D3C916F6DEEAC73294E8268FB5885044A833FC5459588F4A9184CF C41A5766
com.			86400	IN	RRSIG	DS 8 1 86400 20210118050000 20210105040000 42351 . MwUFofCInvHNMje8z2Ep3gmY4AmQI55TN85/CBsZstFDfyJ+8E5i9Q85 zKIti70A2K1M2eoEx9HDCOR8cIG23sYB87ln0ECQaUYyB+eHNh8qoXIH D575KzYomRiKwW+Yf5NVECNy7QpjCxT677jE8noXTgMawtZz/BqJ8q7z GVWuVIlNQrr9KhRcV47jJtxyOOLvFdVlMCWlJ8bR3x/4NEBqNRwCZYT0 9j1btk6Oo8YLmtk2b0zcBgiS7c4UCg4Nj0SFVFHbUUlOp2POgz6nTeC5 Eb5JRWwD1v8xgiY2P86JlOvgBJp8mRlv/L6ussot+vWQgcRH/jyLBe4s nsYJlw==
;; Received 1177 bytes from 192.203.230.10#53(e.root-servers.net) in 14 ms

claramarshall.com.	172800	IN	NS	dns1.p07.nsone.net.
claramarshall.com.	172800	IN	NS	dns2.p07.nsone.net.
claramarshall.com.	172800	IN	NS	dns3.p07.nsone.net.
claramarshall.com.	172800	IN	NS	dns4.p07.nsone.net.
CK0POJMG874LJREF7EFN8430QVIT8BSM.com. 86400 IN NSEC3 1 1 0 - CK0Q1GIN43N1ARRC9OSM6QPQR81H5M9A  NS SOA RRSIG DNSKEY NSEC3PARAM
CK0POJMG874LJREF7EFN8430QVIT8BSM.com. 86400 IN RRSIG NSEC3 8 2 86400 20210112054226 20210105043226 31510 com. ijvrb/k0/+hmY+yTHmJEJpMyRFQpt/+UorRzvrVh5Z7yorZAMe0MnXpP R3K2f9AZ8HhLKN3PSOpizM7Zh4sx/JGbtJTgMky+gaNkh57ll1EB9xKf hHtsHxXXrthRw62dR1Y8Ntt5dU3scZzfmvLT8Wu/tl5E3RjFqxYrmuB8 ZJtFBcVxUfP6zJpLGU6GyuWthuEuK9ohhc/ORPpkozDTKw==
A4U5V8MUH8077NIJ08LHR822OEEQG2D6.com. 86400 IN NSEC3 1 1 0 - A4U6B2LERICNJ1O6KLNBC2UI6M24GO8P  NS DS RRSIG
A4U5V8MUH8077NIJ08LHR822OEEQG2D6.com. 86400 IN RRSIG NSEC3 8 2 86400 20210109065346 20210102054346 31510 com. B9q1g6Ie0jsR7ZCjp0F5QhRdM+eV+41Jr9zkWRw3cAsPQppWJpVat4R0 1FCeTTw/oskI8eGT0KRQAtYR7FRXPvktjdmDM/sl9WD0topfHV5HMy+a o8d1HiBYw3AvF0vyE96rfAoj4qLiKK4CmXZY2UnPKqHobokEawq+w/vA YSMCyortPPQMMZcTuqFpa2f2ddBwJYQOccR2Es34PLDAQQ==
;; Received 684 bytes from 192.48.79.30#53(j.gtld-servers.net) in 48 ms

claramarshall.com.	20	IN	A	54.215.113.85
claramarshall.com.	20	IN	A	54.151.88.132
;; Received 78 bytes from 198.51.44.71#53(dns3.p07.nsone.net) in 33 ms

I’m guessing you will see something different for your local test where the domain isn’t working.

Last but not least, service workers are often to blame:

It would also be helpful to confirm that there isn’t a service worker installed on the system where this domain isn’t working. (The current site isn’t using any service worker but some previous version may have.)

If there are other questions about this issue, please let us know.

@claramarshall You will need to secure your wordpress subdomain outside of Netlify, because it is on a different server.