Support Forums

DNS Record issues -- NETLIFY records, MX records


Netlify site - quirky-yalow-e58f90.netlify.app
Custom domain through Network Solutions - prickly-paradigm.com

I’m totally lost here – I was trying to set up MX records so I could use gmail with our domain name and it screwed everything up. I started getting “DNS_PROBE_FINISHED_NXDOMAIN” errors intermittently, so I was just letting it go for a while, hoping that it was just a problem with the DNS that would resolve itself, but no luck. I thought I could fix the problem, like a fool, by deleting the “IN NETLIFY” DNS records and adding an A record for my apex domain pointed at the Netlify load balancer, but still no luck. Getting the same error message when I try and go to the website. But when I check the httpstatus it says that all the servers for that domain are pointed at Netlify, and I configured the Network Solutions DNS to point to the Netlify name servers.

I’m at a real loss here, and I’m desperate for any help! I’m afraid that trying to fix things myself at this point would just end up breaking more things.

Hi @comartini1992

These records are automatically generated by Netlify when you are using Netlify DNS. These are required.

This is used when configuring external DNS

What I do see are DS records (DNSSEC) which is likely adding to your issues as it is currently not supported. You will need to disable DNSSEC with your registrar.

A couple of options:

  1. Start again: remove your domain from Netlify then re-add it to generate the NETLIFY records again (you can’t simply add them) along with the other records (e.g. MX) you require.
  2. Wait: for a Netlify Support Engineer who can re-add the NETLIFY records for you

Also have a read over this Support Guide which also links to a number of other guides.

Hi! Thank you so much for your help! I figured that at the end of the day I’d just have to remove the domain and re-add it. Just did so, hopefully it will take effect soon? Still not seeing any progress, but fingers crossed!

hi, any changes on this? do let us know.

Unfortunately not :frowning:

It actually was working fine yesterday, but today I started to get the “DNS_PROBE_FINISHED_NXDOMAIN” error message again. Anything else I should be trying?

A little more context – the website is loading fine on phones and mobile devices, but intermittently on desktop browsers. Not sure what that could mean? Really appreciate y’all’s help!

You still have DNSSEC enabled on your domain which is a possible cause (as previously mentioned.) You can find information about disabling DNSSEC in How Do I Manage DNS and Advanced DNS Records? Network Solutions support article.

Name Server: DNS1.P03.NSONE.NET
Name Server: DNS2.P03.NSONE.NET
Name Server: DNS3.P03.NSONE.NET
Name Server: DNS4.P03.NSONE.NET
DNSSEC: signedDelegation
DNSSEC DS Data: 65235 13 4 B51CF0A73DF7147CB2D8F6596132ED720561CCDFF78994E427DE25964802B9E4F0A532BCB22CAB586D19875A41CC3E05
DNSSEC DS Data: 65235 13 2 166058F222F1E43AE54743DF160A9306FAE45AC9D59305A1F6EF052BF0362D8D
DNSSEC DS Data: 65235 13 1 4EFBD8BE3D6C18B121845FCCE49F00A146E6D5CD

Network Solutions is saying that its Netlify’s DNSSEC that is causing the issue, but obvi they’re wrong! I think I got it all fixed now – how do I check to see if I really turned DNSSEC off? The website is working for now!

A simple solution to use Network Solutions Whois. Enter your domain (confirm you aren’t a robot) then look for DNSSEC towards the bottom of the results. It should say unsigned if it is off (just checked and that’s what it says.)