Home
Support Forums

DNS reconfigured, but subdomain doesn't load

I was notified by a visitor that the site was down. It turns out one of the sub-domains is not loading.

• netlify site name:
https://hungry-goodall-aa3618.netlify.app

• DNS name issue:
The custom domain is “victortokaito.com”.
I have matched the DNS records to Netlify, but without the prefix, the site doesn’t load.
With the prefix (the ‘www.’), it works.

I’ve also tried updating the A and CNAMES to no avail.

Hi @victortokaito

I believe you may not have configured your domain as per Delegate your domain to Netlify | Netlify Docs. As an example, here is the setup for one of my domains

I can see you have a CNAME for www.victortokaito.com. When using Netlify DNS you do not require CNAME or A records unless pointing a subdomain to another service.

Hi @coelmay

I’ve updated the name servers on Namecheap to match Netlify’s.
I went ahead and removed CNAME and A records for the site without the ‘www.’

But it looks like the issue is still there. Is it possible I’ve messed up the settings on this DNS panel?

Thank you.

What appears under the Custom domains section of your site now (for hungry-goodall-aa3618.netlify.app?

Hi, this is what it shows now, but without the ‘www.’ it still doesn’t load.

update: I just deleted some CNAME’s and it seems to work. Does it work on your end as well? Thank you

Yes @victortokaito, just loaded it :netliconfetti: