Home
Support Forums

DNS questions for custom domain

Hi, @laura
I am following the step and I want to use subdomain. When I type in Domain Settings , it said please use main domain name, so I use the root domain name and use the submain in A record and CNAME

seem it is point to the right place, but https://www.memori.xplor.hk/ return not found and the keep say it is not secure, any things i go wrong? thanks

Hi, @basarakit. There are several issues.

Issue 1: There is an inactive Netlify DNS zone here:

https://app.netlify.com/account/dns/xplor.hk

There is a support guide about this here but, to summarize, I would recommend just deleting the DNS zone above.

This is preventing the SSL certificate from being assigned. Once you delete the zone it should work.

Issue 2: The domain name www.memori.xplor.hk is not configured for this site here:

https://app.netlify.com/sites/xplormemori/settings/domain#custom-domains

Issue 3: The custom domain which is assigned (memori.xplor.hk) is using an A record when a CNAME is the correct record type.

The existing external DNS record for the site should always be a CNAME unless it is the apex domain. This is not the case:

$ dig +noall +answer memori.xplor.hk CNAME
<NO ANSWER>
$ dig +noall +answer memori.xplor.hk
memori.xplor.hk.	14400	IN	A	104.198.14.52

There is an A record, but a CNAME record is the correct type. This is covered in the external DNS instructions.

Note, there is a CNAME for the www subdomain of that domain:

$ dig +noall +answer www.memori.xplor.hk CNAME
www.memori.xplor.hk.	14400	IN	CNAME	xplormemori.netlify.app.

This is the correct record but remember you need to add it to the site settings also. For the www subdomain to work, you need to add it manually on the same site settings page (found at Site Name > Settings > Domain management > Custom domains).

The www subdomain is automatically added if you add an apex domain to a site, but not if you add a subdomain to a site. If you add xplor.hk then www.xplor.hk is automatically added. However, if you add any other subdomain (like foo.xplor.hk) to the site settings then www subdomain is not added automatically. The www subdomain is only automatic for apex domains.

So, your www.memori.xplor.hk DNS record is already correct, you just need to add it to the site settings at Netlify.

To summarize, do the three things below to fix this:

  1. Delete the DNS zone (because you don’t need it) here.
  2. Add www.memori.xplor.hk here.
  3. At the current DNS service add (which I think is bluehost.com) delete the A record for memori.xplor.hkand replace it with a CNAME similar to the existing record forwww.memori.xplor.hk` like this below:
www.memori	14400	IN	CNAME	xplormemori.netlify.app.

Remember, you are doing step three at Bluehost and not Netlify DNS - you are deleting the Netlify DNS zone in step 1.

After you do this SSL provisioning should work.

If there are other questions or if this does not work , please let us know.

Thanks @luke, I finish the setting and it should be work now. I read the article said that do not use CNAME without www because the email or other function wont working. I think it is only for the root domain which mean submain should be use CNAME instead of A record?

thanks for the detailed instruction. I am quite messy in several topics in the forum talking about DNS setup.

Hi, @basarakit. Yes, the A record is only for the root domain. For all subdomains, please use the CNAME.

I checked the current DNS configuration and everything looks perfect to me know.

If there are other questions, please let us know and we will be happy to answer.

Hi! I am experiencing a very similar issue, where www.sitename.com totally works, but the sitename.com redirect does not work. I am using a third-party registrar.

The DNS configuration instructions in my Netlify account direct me to create an A record for sitename.com A 75.2.60.5, which I have done (Although, I have seen some forum comments suggesting that sitename.com should actually be replaced with an @ symbol, or be left blank).

It should also be noted that I did not remove the nameservers that were already in place at the registrar. Is this something I am supposed to do? I have included a screenshot. Maybe I just need to kills those? Or perhaps there’s another step I am missing?

Thank you!

This depends on the registrar. See documentation from your registrar as to the correct method.

This is fine.

As long as you have the records pointing to Netlify as specified when configuring your custom domain.

Interesting. Ok. Thanks for such a quick reply. I will take a look at their documentation and post my findings.

@coelmay Thank you for your help. Changing the A record to @ worked. But now I am seeing a security warning. I click “renew certificate” in Netlify and I am seeing both domains. Do I just need to give it a minute?

Thanks!

This is resolved. Thanks again.

1 Like

Glad to hear everything is working for you, @badcopy. Thanks for letting us know!

1 Like