I’m only able to go to my site on my computer but from my cellphone or other friends can’t see my website they get this error DNS_PROBE_FINISHED_NXDOMAIN Error this happened after I changed my dns records to google’s in the dns panel this is the message I get on the dns config => “There’s a Netlify DNS zone for this domain, but no DNS records associated with it. Please [contact support] for setting up DNS records.”

@Miguel787 Welcome to the Netlify community. Did you try searching for that error here on the forum? I think you’ll find it’s been discussed many, many times.

Hi @gregraven Yea i saw the other ones but I don’t think they address the same issues I’m having one talks about route 53 which i cant find

Hey there, @Miguel787 :wave:

Thanks for reaching out, and welcome to the Netlify Forums :netliconfetti: Here is a thread that discusses this issue and Route 53. Please walk through these debugging steps and let us know if that works for you!

If it doesn’t, please provide your Netlify site name. :slight_smile:

hi @hillary my netlify site name is goofy-mayer-4c2855 I’m still new to this web development stuff but im not using aws like the person on that thread so i dont think i need route 53. originally my issue was i was trying to get my email from google domain to work with my domain name i bought from google so i changed the dns settings on netlify and then i noticed i only could see the domain on my desktop but not on any other computer. just trying to give more context.

hi @Miguel787 , we’d need to know the custom domain you are trying to work with to assist, would you mind sharing it?

sorry @perry custom domain name is mcruzlehardy.dev

@Miguel787 You seem to have delegated your DNS to Netilfy AND entered the “for external DNS only” settings into your Netlify DNS panel. This is unnecessary and stringently recommended against by Netlify. As a result, only your apex domain is served by Netlify, and only under HTTPS.

|====================== get x-nf-request-id =====================
| -------------------- blank if not Netlify ---------------------
| ---------------------- mcruzlehardy.dev ----------------------
| ---------------------------- http -----------------------------
| ---------------------------- https ----------------------------
< x-nf-request-id: ac4b1606-3298-4ba0-93b0-cf25bddc028b-234721502
| -------------------- www.mcruzlehardy.dev --------------------
| ---------------------------- http -----------------------------
| ---------------------------- https ----------------------------

My recommendation would be to review your DNS entries and get them into alignment with best practices, and go from there.

so this is my dns panel now this is how I had it this morning when I started working on it. i tried adding the “for external dns only” settings in an attempt to fix it but it didn’t work either

@Miguel787 You should also have two or four Netlify auto-entries, and you should consider adding a Google verification TXT entry if you don’t already have one.

@gregraven where can I find the auto entries? sorry I’m super new to all this

If you have set up your custom domain correctly, they should be right next to the MX entries that you shared in the screen shot.

When i was adding in the google ones I deleted the ones that were there thinking i had to replace them. is there somewhere i could find them to manually put them in?

I don’t know. You deleted the DNS entries that allow your site to work on Netlify. They’ll look something like this, but I don’t know how you enter them. You might have to wait until Netlify support can step in.

Alternately, you could delete this from your account and then re-add it, although you might have to re-enter your Netlify name servers with domains.google.com afterward.

1 Like

Thank you @gregraven I appreciate it ill wait and see if they help again but at least we found where i made my mistake. If all else fails ill just do like you said delete it and redo everything

Hi, @Miguel787. We also have a support guide about migrating to Netlify DNS here:

I do show that Netlify DNS is correctly configured and working at this time:

Name server records (type = NS):
mcruzlehardy.dev.	3599	IN	NS	dns1.p07.nsone.net.
mcruzlehardy.dev.	3599	IN	NS	dns2.p07.nsone.net.
mcruzlehardy.dev.	3599	IN	NS	dns3.p07.nsone.net.
mcruzlehardy.dev.	3599	IN	NS	dns4.p07.nsone.net.

Records for the apex domain (type = A):
mcruzlehardy.dev.	19	IN	A
mcruzlehardy.dev.	19	IN	A

Records for www subdomain:
www.mcruzlehardy.dev.	19	IN	A
www.mcruzlehardy.dev.	19	IN	A

The IP addresses above are for ADN nodes closest to me. If you see different IP addresses when you check, that is expected so don’t worry if you see something different.

I also see the SSL is provisioned and working now. It looks like your were able to resolve this.

As the support guide above states, one thing to be sure of that that you have copied any DNS records you need for other services to Netlify DNS (meaning any DNS records for email configuration, sites hosted elsewhere, verification TXT records for services like Google, etc.).

If there are any other questions, please let us know.