Home
Support Forums

DNS Nightmare ! Primary Domain working but no redirecting without "www"

Project : gurukirandnayak.netlify.app
Primary domain(Working) : www.gurukiran.net
Not Working: gurukiran.net (not redirecting automatically to primary domain ).

I followed this to full extent.

Hi @GurukiranDNayak

Both domains are working for me, and gurukiran.net is redirecting to www.gurukiran.net (both HTTP and HTTPS.)

Have you tried using a different browser? Have you tried opening an incognito/private window?

2 Likes

Yes I did. It’s not working.
Just try HTTP first i.e (gurukiran.net) it won’t work.

Working.

gurukiran.net

Your issue is likely local caching (your computer/network.)

1 Like

Thank you for you response I will try to clear my cache and try it out once more.

Hi @GurukiranDNayak,

Like coelmay mentioned, both sites are working for me as well, both http and https. Using DNSChecker.org it also seems to have propagated for both A Records (for gurukiran.net) and CNAME (for www.gurukiran.net). I also see that a SSL certificate has been created on your site. Let us know if you’re still having issues. Thanks!

2 Likes

Thank you @Melvin and @coelmay both of them work fine for me as @coelmay mentioned it was the network issue on my side.

3 Likes

Thank you for letting us know! Glad everything is up and running.

Thank you ma’am @Hiliyeh !

1 Like