Home
Support Forums

DNS Name Servers not working, not sure its because Host doesn't allow certain names

Hello Everyone,

This is my first time hosting a domain on Netlify, and I need some help.


General Information:

Netlify Site Name: https://datatechgroup.netlify.app/

Custom Domain: https://datatechgroup.com/


Hello I am having trouble updating my Name Server on my DNS. I know how to update the name server I am just not sure if its set up correctly.

I have my domain on PureHost ( https://www.purehost.com/ ). There I have my 4 name servers Netlify provided to me:

dns1.p06.nsone.net
dns1.p06.nsone.net
dns2.p06.nsone.net
dns3.p06.nsone.net
dns4.p06.nsone.net

The problem is in PureHost, they do not accept name servers that do not start with the letters ns.

I still went ahead and tried to see if it will work with just “ns1.p06.nsone.net

After about 12 hours and more, I am not seeing no changes, after checking DNS propagation sites
seeing that everything is okay. I am still not seeing no change, I am starting to believe I need to have the “dns” part instead of just the “ns” in the name server for it to propagate correctly.

I am I thinking the wrong way about this or the correct way about this?

Do I need to change anything here? Netlify hasn’t been able to Verify the DNS still when I click on “Verify DNS” by the Certificate section. If need more information, I be happy to provide.

Hi @Sorumeiji

Based on the image you shared, this is adding a nameserver to the DNS entries with Purehost as opposed to allocating DNS to Netlify. They do have a guide How to Change or Update NS Records - DNS Management which walks through changing the nameserver to those provided by Netlify.

1 Like

Hey @coelmay thank you so much for the response. I seen this, but in the screenshots on the link you provided, you see how their example says ns1.example? Netlify starts with dns1.example.com. Purehost doesn’t let me update the name servers because of this. Its super weird, I must type in a NS that starts with ns not dns. That is why the update DNS is greyed out in my screenshot. If I take off he “d” it will go through.

Then I would contact Purehost’s technical support for assistance.

1 Like

Oh, so Netlify does need the full name spelling dns1.example.com to make it work?

So this is incorrect?

You need to enter the records Netlify provided exactly as they are provided.

I.E.

The screenshots you are providing do not match those in the support article I shared.

1 Like

@coelmay I knew that might be the case. Thanks for clearing that up. I have no idea why they made their system like that, but I guess it make sense too. Most hosing companies always have ns at the start, but…first system I seen that had that check in place. I’l talk to PureHost support and see what actions I can take. I appreciate your help, and your time on this issue.

Your screenshot shows Edit DNS Record, while the screenshot in the article I linked to shows Edit your nameserver. I believe you are possibly editing the wrong section which is why it is not working.

1 Like

I am giving it a shot now.

Seems like that is the case after following instructions. Because Netlify name servers start with the letter “d” I cannot use their name server, I can only use a name server that starts with “ns”

This restriction doesn’t make sense to me either. Have you contacted their support and got a response yet?

1 Like

@hrishikesh My manger and I are going to get in contact with the business owner of the account today, I need some details before they will help me. I wanted to ask, if I can use name server through IP address instead? Would that work, by using NSlookup?

As far as I know, nameservers are always hostnames and not IP Addresses.