Support Forums

DNS issues with .ie hosting

Hi Guys!

I’ve managed to get a deployment working and have been trying to use my domain davehill.ie to redirect to my site.
I have been trying a few different configurations but haven’t managed to get both davehill.ie and www.davehill.ie to redirect to my app. I had tried to update my domain providers nameservers to use the ones that are shown in the “Check DNS Configuration” warning message but it won’t let me. When I spoke to the domain provider they told me I couldn’t update the nameservers because:
“A .ie domain needs DNS records setup and active on the new name servers before you can switch, this is a requirement by the IEDR that manage .ie domains.”

So then I tried adding the loadbalancer as a DNS record and that seemed to allow the apex domain to work but with the www prefix, it failed, which was the primary domain. I’ve tried switching the apex domain to the primary domain but it’s annoying me that I can’t get the WWW working.

I’ve added the DNS records from my domain provider which can be seen below:

I’ve just tried to remove the DNS record on my domain hoster to check something else and currently my domains look like this:

But at this point I think I need to seek assistance :slight_smile: Please help me figure out what I’m missing here.

Appreciate any help given!

Hi, @DaveHill. I think you are running into this issue:

This domain isn’t using Netlify DNS at this time:

$ whois davehill.ie | grep "Nserver"
Nserver:                 ns1.blacknight.com
Nserver:                 ns2.blacknight.com

Please use one of the two solution for this listed in the support guide to resolve this. If there are questions about either solution, please let us know and we will be happy to answer.

Hi Luke!

Apologies for the delay in getting back to you on this. I tried changing the nameservers on the registrar today and it just worked. it must have needed time to propagate I suppose? Main thing is now that it seems to work :slight_smile:

Thanks for your help and advice!!


Hi, @DaveHill. Changes to almost any DNS record will have a delay. Those delays are controlled by the previous, not the current DNS record.

There is more about why in the following support guide:

If there are other questions, please let us know and we’ll be happy to answer.