DNS help - A record + CNAME not sufficient for custom domain redirect?

Hello,

I’m trying to point a domain to Netlify using A/CNAME records. Typically I’d just update the nameservers, but there’s an active mailserver. My first attempt was to go via Netlify DNS and duplicate the MX/SPF records, but while the domain worked email wasn’t able to be received after that so I’m taking a different route.

URLs:

Record updates:

  • A: sydneyhandtherapy.com.au. | 104.198.14.52 (period after domain was automatically appended)
  • CNAME: www | practical-fermi-1c138d.netlify.app. (period after domain was automatically appended)

I’ve tried to debug via DIG, however I’m not able to come up with a solution. Full DNS config attached:

Please enlighten me!

@Farren How long ago did you make these changes? I’m seeing the CNAME entry but not the A record, and your site is still being served from elsewhere than Netlify.

Remember that it can take 48 hours for DNS changes to propagate.

|===================== curl check for server ====================
| ---------------------- should be Netlify ----------------------
| ------------------ sydneyhandtherapy.com.au ------------------
< Server: Apache

| ---------------- www.sydneyhandtherapy.com.au ----------------
< Server: Apache
|================================================================

Hi Greg, thanks for your response.

Changes were made about 5 days ago. Could there be an issue with the DNS provider? Records not properly being set or some such? I’m not sure how much of a thing that is.

@Farren Netlify has reported an issue with the load balancer IP address. Have you tried changing to the new load balancer IP address – 75.2.60.5?

OK, I’ll update the A record and cross my fingers for up to 48 hours :slight_smile:

Hi, @Farren. The current DNS records I see still do not point to Netlify:

Name server records (type = NS):
sydneyhandtherapy.com.au. 21599	IN	NS	ns1.sphost7.com.
sydneyhandtherapy.com.au. 21599	IN	NS	ns2.sphost7.com.

Records for the apex domain (type = A):
sydneyhandtherapy.com.au. 14399	IN	A	199.167.200.41

Records for www subdomain:
www.sydneyhandtherapy.com.au. 14399 IN	CNAME	sydneyhandtherapy.com.au.
sydneyhandtherapy.com.au. 14399	IN	A	199.167.200.41

It looks like you have your DNS zone NS records pointing to sphost7.com and not to partnerconsole.net.

This means that your DNS changes at partnerconsole.net are being seen by anyone else on the internet. Note, the records work there is you test manually:

$ dig sydneyhandtherapy.com.au @ns1.partnerconsole.net

; <<>> DiG 9.10.6 <<>> sydneyhandtherapy.com.au @ns1.partnerconsole.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24392
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;sydneyhandtherapy.com.au.	IN	A

;; ANSWER SECTION:
sydneyhandtherapy.com.au. 3600	IN	A	75.2.60.5

;; Query time: 184 msec
;; SERVER: 203.55.143.4#53(203.55.143.4)
;; WHEN: Fri Mar 26 01:50:50 PDT 2021
;; MSG SIZE  rcvd: 58

However, because those are not the authoritative name servers (NS records) for the domain, no one on the internet will ever see those records until you fix this.

You will need to make the authoritative name server changes at your registrar for the partnerconsole.net records to take effect.

Ah, I admit I’m a little hung up on the whole nameserver business. Typically when I deploy via Netlify I update the nameservers, however in this case doing so would disrupt existing email services.

I’m still uncertain of which approach I should be focusing on:

a) Retain original nameservers and add A/CNAME records (which admittedly has been unsuccessful). Does this approach fundamentally not work? I’m still getting my head around DNS.

b) Update nameserver records to Netlify’s and duplicate existing MX/etc. records. I had first attempted this but was unsuccessful in retaining a functioning email service – they ceased to appear in the expected inboxes. Here’s the config I used:

It would be great to understand if option A is fruitless or not, and if so then what I can expect when trying to retain the connection to an existing mailserver while forwarding the records through Netlify DNS.

Really appreciate your time and expertise, thank you.

Hey Farren and sorry to hear about the ongoing struggle!

I think you are pretty close without a DNS transfer, which would be some work at least! So, here’s what I’d recommend as most likely to be expedient path forward:

  1. contact the sp7host tech support team
  2. let them know you are trying to set the following records, and could they guide you in doing so?
  • sydneyhandtherapy.com.au A 75.2.60.5
  • www.sydneyhandtherapy.com.au CNAME practical-fermi-1c138d.netlify.app

I think they’ll help you get those in place, and that will cause no potential interruption to or malfunction of your email service in the meantime. While we can probably help debug the email failures - we probably won’t be fast at it so this way should minimize impact for you!

Hi @fool, no worries!

What confuses me about your response is that I believe I already have the two records you mention in place:
image

However, I will follow up with sphost support and update with results.

Thank you!

@Farren Not according to dig.

|====================== dig A record(s) for =====================
| ------------------ sydneyhandtherapy.com.au ------------------
| ------------ Netlify's old load balancer: 104.198.14.52 -----------
| -------------- Netlify's new load balancer: 75.2.60.5 -------------
199.167.200.41
Organization:   PrivateSystems Networks (KNOWN-1)

See the documentation here:
https://docs.netlify.com/domains-https/custom-domains/configure-external-dns/
|================================================================

Hence:

|===================== curl check for server ====================
| ---------------------- should be Netlify ----------------------
| ------------------ sydneyhandtherapy.com.au ------------------
< Server: Apache

| ---------------- www.sydneyhandtherapy.com.au ----------------
< Server: Apache
|================================================================

contact the sp7host tech support team

This was all it took in the end. They were able to update the records and everything appears to be behaving as expected now.

Thank you very much for your assistance @gregraven @fool @luke

Hi, @Farren. Thank you for taking the time to share the solution here and I’m glad to learn it is working now. :+1: