Support Forums

DNS configuration failed and A DNS zone for this domain already exists on NS1

Hi all,

I have recently updated my Default subdomain name given to me by Netlify. I have also updated my CNAME to farida-portfolio.netlify.app, I did this two weeks ago. However, i still get an DNS configuration error. In addition, I have also added A record for faridaalin.com pointing to o104.198.14.52

Then I tried to use Netlify DNS and when I tried to verify my domain to Netlify I got his error: “A DNS zone for this domain already exists on NS1”. I created DNS zone for this domain the first time I got the page up, which is over a year ago. " I have not used other services for this domain, only Netlify. I bought my domain name from Proisp and they can’t seem to see any issues in their side.

I have also read this topic: [Support Guide] I'm getting errors when adding my domain to Netlify or configuring DNS zones

I have deleted my domain and re-added, but the errors is still the error.

Netlify site name: https://farida-portfolio.netlify.app/
Custom domain: www.faridaalin.com
DNS configuration: I have pointed www CNAME record to farida-portfolio.netlify.app

Thank you :slight_smile:

@farida You have a couple of issues with your DNS settings.

For example, you have tried to delegate DNS to two different sets of name servers:

|===================== whois name server for ====================
| ----------------------- faridaalin.com -----------------------
   Updated Date: 2020-09-11T09:12:14Z
   Name Server: DNS1.P01.NSONE.NET
   Name Server: DNS2.P01.NSONE.NET
   Name Server: DNS3.P01.NSONE.NET
   Name Server: DNS4.P01.NSONE.NET
   Name Server: NS2.PROISP.NO

Depending on how you want to set up your system, you should probably delete the entry for NS2.PROISP.NO.

Next, the Netlify name servers you have entered don’t match each other somehow:

|==================== dig name server(s) for ====================
| ----------------------- faridaalin.com -----------------------
| ------------------- should agree with whois -------------------

You should be using either p01 or p02, or whichever name servers Netlify has assigned your site.

Let us know what happens after you get these issues corrected.


I have now deleted Name Server: NS2.PROISP.NO, but I am unable to update the name servers from Netlify as I am still getting this error: “A DNS zone for this domain already exists on NS1”.

Thanks :slight_smile:

@farida If you don’t know who established that other site using this domain name or where to edit it, you’re going to have to verify your ownership/control of the domain name to Netlify tech support and have them resolve it.

Also, despite your edit, whois says that the name servers for your site are p01.nsone.net while dig says the name servers are p02.nsone.net, although maybe this will get straightened out once you have only one version of your custom domain on file with Netlify.

Hi again,

I established the site and I did verify it the first time. I don’t know how to explain it, but this site was working fine and was verified until I changed the url netlify gave me. I have changed the DNS records in cpanel to match Netlify, hopefully this works soon.

Thanks :slight_smile:

Hi, @farida. We cannot make a DNS zone for this domain. We use NS1 for our DNS infrastructure. Many other hosting companies do as well. NS1 has many customers.

Someone (not Netlify) already made a DNS zone for your domain there so that will need to be deleted before we can do so.

See this thread for example:

Hi, I have now deleted all DNS belonging to my domain. I have checked https://dnspropagation.net and there is not DNS record for my domain name. Also checked Dig (DNS lookup). From here I should be able to add NS1, but am still facing the same error. I and I really dont know how to solve this.

Kind regards,

Hi, @farida. To be clear, we (meaning Netlify) cannot fix it from our side.

Most people report that writing an email to support@ns1.com helps them to resolve the issue if nothing else does.

If you email them, you might say something like this:

Hi NS1 Support Team,

I’m trying to make a DNS zone at Netlify for my domain, which is faridaalin.com. When I do this though, I get an error that says:“A DNS zone for this domain already exists on NS1".

Can you help me get that DNS zone deleted (or tell me who created it)?

This will be something that NS1’s technical support team has done many times before. They will know exactly what you mean and they will almost certainly be able to help you.

Also, I’ve never emailed them about this type of issue myself. (I would email them but the owner of the domain must be the one to send email. It is always someone else’s domain and therefore they must be the person to email.)

If emailing them works (and I really do think it will), it would be great to learn what sort of questions they ask you.

Knowing what they require to prove ownerships is my biggest question. This would help me to tell people what to expect when emailing NS1’s technical support team. You don’t have to report back here if emailing them fixes this but, if you are willing to do so, we would certainly appreciate learning about that the support experience as NS1.

Either way, please do reply here anytime if there are other questions about this.

I contacted the support team at NS1. In order for the support team to help me I had to create an account https://ns1.com and then send the email, using the same email I registered on my account at NS1. This is the answer I got back:

Hi Farida,

Thank you for reaching out regarding this zone collision. This zone was previously delegated to NS1 without existing on the NS1 platform so a hold was placed (creates this zone in an internal account) on this zone. This prevents any hijacking of these zones by malicious actors between the delegation and creation steps.

This zone was stored in this internal account and has now been removed. Please proceed with your zone creation process.

NS1 recommends all zones are created within the platform prior to delegation to avoid risk and prevent zone collision interruptions.

Please let us know if you need anything else!
Best Regards,

Customer Support

I am at least not getting the previous error and I think I am able to add my domain now. :crossed_fingers: :slight_smile: