Direct URL has not worked since Nov 20


We’ve got 404 page when trying to access pages directly through url below.
However accessing the same path through the top page works fine.

This issue has occurred since Nov 20 even though our git code has not been changed since Oct 21.
Based on the code, out app is built and deployed on a daily basis and all direct URLs had worked fine until Nov 19.

page url - does not work
page url built on Nov 20. - does not work
page url built on Nov 19. - works

I wonder what brought this issue since nothing has changed on our git code.

Could you please help me solve this problem?


Hi @kxn

I apologize but I don’t think I am understanding the issue correctly. I do see the issue with the links to the deploys you provided. However, I found your site in the Netlify UI and visited it by using the direct URL: and it appears to serve up correctly. Did you perhaps fix the issue? Are you still seeing the problem?

Hi @elden,

I’m still seeing the problem.

All accesses to a page from the top page work fine.
But the problem is that a DIRECT URL ACCESS to a ‘/post/xxx/’ page does not work.

Since my English might be not clear, I tabularized our situation as below.

type of page Access
from the top page
Direct Access
thru URL
until Nov.19
Direct Access
thru URL
since Nov.20
/ (top-page) - ok ok
/topic/xxx/ ok ok ok
/post/xxx/ ok ok NG

Also, you can see the situation on the following video.

As I wrote, this situation started to happen on Nov 20. even though our git code has not been changed since Oct 21. So we have no idea what should we do to solve this.

Could you please help us?


Hi, @kxn. The file you are asking about (which is the file with the name and path /post/zfe8e98a3fdd172789a5ed3d87396f014/index.html) does exist for the deploy on the Nov 19. You can see it in the logs here:

However, for the current deploy that file does not exist and it also is not mentioned in the logs here:

I’m not sure why one build mentions the file and the other does not because the repo itself is private. All I can see is that the later build is not creating that page. To understand why, I need to see the code in the repository and I cannot see it.