Home
Support Forums

Deploys works, but doesn't include my commits

Hi guys

I am encoutering an issue when a build is triggered on #### nervous-wiles-413e02.netlify.app.

The stages are :

  1. Commit to gitlab → ok, I can see my files
  2. Build is triggered on netlify ->ok
  3. when I try to visit the new page I get the netlify 404 page.
  4. The build archive doesn’t contain my new files committed

I tried to clear the cache → didn’t work.

Any idea ? Thanks for your help !

Here is the log of the build


## Deploy summary

9:45:53 PM: Build ready to start
9:45:54 PM: build-image version: dd2f6d8803393d46ac35a4f752a5a46f254c0300
9:45:54 PM: build-image tag: v3.9.1
9:45:54 PM: buildbot version: 04fb57a6b52e36fc0fd306c97e17aa22ebf93b50
9:45:55 PM: Building without cache
9:45:55 PM: Starting to prepare the repo for build
9:45:55 PM: No cached dependencies found. Cloning fresh repo
9:45:55 PM: git clone git@gitlab.com:fizz-buzz/mounou.com
9:46:00 PM: Preparing Git Reference refs/heads/master
9:46:03 PM: Parsing package.json dependencies
9:46:03 PM: Starting build script
9:46:03 PM: Installing dependencies
9:46:03 PM: Python version set to 2.7
9:46:05 PM: v12.18.0 is already installed.
9:46:05 PM: Now using node v12.18.0 (npm v6.14.4)
9:46:06 PM: Started restoring cached build plugins
9:46:06 PM: Finished restoring cached build plugins
9:46:06 PM: Attempting ruby version 2.7.1, read from environment
9:46:07 PM: Required ruby-2.7.1 is not installed - installing.
9:46:07 PM: Searching for binary rubies, this might take some time.
9:46:07 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
9:46:07 PM: Checking requirements for ubuntu.
9:46:08 PM: Requirements installation successful.
9:46:08 PM: ruby-2.7.1 - #configure
9:46:08 PM: ruby-2.7.1 - #download
9:46:09 PM: ruby-2.7.1 - #validate archive
9:46:14 PM: ruby-2.7.1 - #extract
9:46:17 PM: ruby-2.7.1 - #validate binary
9:46:18 PM: ruby-2.7.1 - #setup
9:46:19 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
9:46:19 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems........................................
9:46:20 PM: ruby-2.7.1 - #generating global wrappers........
9:46:20 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
9:46:20 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
9:46:21 PM: ruby-2.7.1 - #generating default wrappers........
9:46:21 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
9:46:22 PM: Using ruby version 2.7.1
9:46:22 PM: Using PHP version 5.6
9:46:22 PM: Started restoring cached go cache
9:46:22 PM: Finished restoring cached go cache
9:46:22 PM: go version go1.14.4 linux/amd64
9:46:22 PM: go version go1.14.4 linux/amd64
9:46:22 PM: Installing missing commands
9:46:22 PM: Verify run directory
9:46:24 PM: ​
9:46:24 PM: ────────────────────────────────────────────────────────────────
9:46:24 PM:   Netlify Build                                                 
9:46:24 PM: ────────────────────────────────────────────────────────────────
9:46:24 PM: ​
9:46:24 PM: ❯ Version
9:46:24 PM:   @netlify/build 18.17.0
9:46:24 PM: ​
9:46:24 PM: ❯ Flags
9:46:24 PM:   baseRelDir: true
9:46:24 PM:   buildId: 61673770b40e2112e0d4cb33
9:46:24 PM:   deployId: 61673770b40e2112e0d4cb35
9:46:24 PM: ​
9:46:24 PM: Creating deploy upload records
9:46:24 PM: ❯ Current directory
9:46:24 PM:   /opt/build/repo
9:46:24 PM: ​
9:46:24 PM: ❯ Config file
9:46:24 PM:   No config file was defined: using default values.
9:46:24 PM: ​
9:46:24 PM: ❯ Context
9:46:24 PM:   production
9:46:24 PM: ​
9:46:24 PM: ────────────────────────────────────────────────────────────────
9:46:24 PM:   1. Build command from Netlify app                             
9:46:24 PM: ────────────────────────────────────────────────────────────────
9:46:24 PM: ​
9:46:24 PM: $ hugo
9:46:24 PM: Building sites …
9:46:24 PM:                    | EN
9:46:24 PM: +------------------+----+
9:46:24 PM:   Pages            | 19
9:46:24 PM:   Paginator pages  |  0
9:46:24 PM:   Non-page files   |  6
9:46:24 PM:   Static files     | 17
9:46:24 PM:   Processed images |  0
9:46:24 PM:   Aliases          |  0
9:46:24 PM:   Sitemaps         |  1
9:46:24 PM:   Cleaned          |  0
9:46:24 PM: Total in 65 ms
9:46:24 PM: ​
9:46:24 PM: (build.command completed in 301ms)
9:46:24 PM: ​
9:46:24 PM: ────────────────────────────────────────────────────────────────
9:46:24 PM:   2. Deploy site                                                
9:46:24 PM: ────────────────────────────────────────────────────────────────
9:46:24 PM: ​
9:46:25 PM: Starting post processing
9:46:24 PM: Starting to deploy site from 'public'
9:46:24 PM: Creating deploy tree 
9:46:24 PM: 0 new files to upload
9:46:24 PM: 0 new functions to upload
9:46:24 PM: Site deploy was successfully initiated
9:46:24 PM: ​
9:46:25 PM: Post processing - HTML
9:46:24 PM: (Deploy site completed in 175ms)
9:46:25 PM: ​
9:46:25 PM: ────────────────────────────────────────────────────────────────
9:46:25 PM:   Netlify Build Complete                                        
9:46:25 PM: ────────────────────────────────────────────────────────────────
9:46:25 PM: Post processing - header rules
9:46:25 PM: ​
9:46:25 PM: (Netlify Build completed in 579ms)
9:46:25 PM: Post processing - redirect rules
9:46:25 PM: Post processing done
9:46:25 PM: Caching artifacts
9:46:25 PM: Started saving build plugins
9:46:25 PM: Finished saving build plugins
9:46:25 PM: Started saving pip cache
9:46:25 PM: Site is live ✨
9:46:25 PM: Finished saving pip cache
9:46:25 PM: Started saving emacs cask dependencies
9:46:25 PM: Finished saving emacs cask dependencies
9:46:25 PM: Started saving maven dependencies
9:46:25 PM: Finished saving maven dependencies
9:46:25 PM: Started saving boot dependencies
9:46:25 PM: Finished saving boot dependencies
9:46:25 PM: Started saving rust rustup cache
9:46:25 PM: Finished saving rust rustup cache
9:46:25 PM: Started saving go dependencies
9:46:25 PM: Finished saving go dependencies
9:46:28 PM: Cached ruby version 2.7.1
9:46:28 PM: Build script success
9:46:54 PM: Finished processing build request in 59.68925746s

Hi, @fizz-buzz. It is a private repo so I cannot test your build directly. However, it doesn’t look like you are manually setting the Hugo version. Adding a HUGO_VERSION build environment variable set to the same version of Hugo that you use locally may be the solution. You can add that environment variable here:

https://app.netlify.com/sites/nervous-wiles-413e02/settings/deploys#environment

If that doesn’t resolve the issue, please let us know.

Hi @luke ,
Many many thanks for your reply. That’s solved the issue !
Have a nice day !