Home
Support Forums

Deploys not publishing

I am experiencing some publishing issues with my website. My deploys have not been published since October 6th and there has been no indicator as to why. I have not changed any settings or done anything differently in my deploying process to cause this sudden problem.

Hi there, @cocooper :wave:

Thanks for reaching out, and welcome to the Netlify Forums. Before we can help you, we need a little more information on the issues you are facing.

Please share:

  • the name of your build instance: “example-jones.netlify.com
  • your package.json
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console

Hi! Here is the extra info… this project is academic so my knowledge in this area is not extensive.

https://albertachickenballs.netlify.app

I am unfamiliar with the package.json you are referring to… do I need to make one?
I have tried manual deploys and resetting the auto-publishing.
I did notice that netlify had mentioned in the notification area that they were recently investigating some publishing issues however mine were never resolved.

Hi there, @cocooper :wave:

Great question. Your package.json is a file that essentially holds your various dependencies needed in order for your project to work! That being said, if your site is not npm/ yarn based, then you won’t have one! My apologies for jumping over that when I first asked-- I skipped a step.

A better thing here to share is how you deploying (uploading) your site? Are you dragging and dropping it or deploying it from github / gitlab?

Ah yes, I am deploying by dragging and dropping the raw files.

Hi @cocooper,

I just checked our logs and it looks like the file upload from your browser to our servers is never really finishing. Our logs still say that waiting for those files to be uploaded. I think you should use Netlify CLI or Git-based deploys to avoid such errors.

Hello and thanks for the support,

Are there any common reasons why project folders fail to upload to netlify servers? I have done nothing different to deploy my site and the only changes to my folder are within the index.html and CSS files to update the code. The size of my project folder is only 1.4 MB so it is still fairly small. If I were able to figure out why my files aren’t uploading from my browser to your servers that would be ideal.

Thanks for your assistance,

Cole Cooper

Hi @cocooper,

That’s all I see in our logs. I see you’re trying to upload 24 files and it’s still stuck in the uploading state.

I do see some file were uploaded, but apparently the process never completed and our backend is still waiting for all those files to finish uploading.

This can happen due to browser extensions, or network issues too. Would you be able to try a different network or device?

Hi,

Thanks for the information. I have cancelled all deploys that have failed to publish on my end. Is it possible to remove anything on yours?

I can definitely try uploading again on a new device or different network.

Again, appreciate the help

Cole Cooper

There’s nothing to remove on our end. If you’ve cancelled it, you’re good to go.