Support Forums

Deploying new site takes forever


Since yesterday I’ve been having issues with deploying a new site to Netlify (manual deployment).
Before, the deployment would take no longer than an eye-blink, but now the cog is running and turning without stopping and the deployment remains forever on step 1: “deploying your site”.

The site I’m trying to upload (via drag and drop) is no different than the previous sites and consists of and simple HTML , a CSS file, and some small images -if any.

I have no (internet / connectivity) issues with other pages
I tried signing off and signing in but didn’t help
Although there aren’t any “forms” in my pages, I also tried uploading by disabling the “forms check” in the deployment settings, without success.

Anyone else experiencing similar issues?

Proposed name of the site of the deployment that is running as I write this message: boring-engelbart-a569c2

Thanks for your help and advice.


Hi, @polygonStorm. Are you perhaps using Bitdefender anti-virus? If so, it has been reported as blocking any form submission data. You might try making an exception in the anti-virus software for our site.

While I don’t recommend disabling anti-virus, you might consider doing so temporarily as a test.

If that doesn’t resolve the issue, my next recommendation would be to make a HAR file recording of the upload.

Please don’t post that publicly though as it will contain your authentication token by default. If you make a HAR file of the issue, please private message (PM) us and we will work out a way to exchange it securely.

Hi @luke ,

Thanks for getting in touch with me about this issue. Indeed I use Bitdefender anti-virus, but up to now, I’ve never encountered this problem, although I’ve been using the same anti-virus for as long as I can remember.

Excluding Netlify in the Bitdefender’s list didn’t help, still, the upload/deployment got stuck on step 1.

However, the problem was solved and I was able to deploy a new site in an eye-blink when I turned off Bitdefender completely during the upload/deployment.

I suppose I’m not the only one using Bitdefender and experiencing this problem. Do you know if this is something being addressed (by Netlify) or is using Bitdefender going to continue to be an issue?

Thanks for your feedback.

Kind regards,

Hi, @polygonStorm. If Bitdefender is interfering with traffic for a site, their instructions for creating an exception is found here:

If it were possible for us to override the Bitdefender block that would also mean it would be possible for malicious websites to override Bitdefender as well. Clearly, Bitdefender is designed in a way that no website can override the blocking it does.

To summarize, Netlify cannot fix this. Only Bitdefender can fix this (as they are the one causing it). Again, the short-term solution is to create an exception. If the exception you created didn’t work you may need to add additional domains to the exception list.

At the very least, I recommend making exceptions for this domains:

  • app.netlify.com - the site domain
  • api.netlify.com - the API domain
  • launchdarkly.com - used for feature flags
  • sift.com - used for fraud prevention

If you still cannot use the site after making those exceptions, please let us know.

1 Like