Home
Support Forums

Deployed website only home page is coming

Hi!
Deployed website only home page is coming rest of pages showing view source code please help me out Thanks below the url of my website.
https://doctor1.netlify.app/

Hi @Rohaaa

Curious.

The reason the page source is shown is due to the Content-Type header

content-type: text/plain; charset=UTF-8

Do all your files have a .html (or .htm) extension?

this is the elementor website which i have created static and deploy on netlify

How is it deployed? Via drag-and-drop, pushed from git? Are you able to share/show the files being deployed?

Have you tried downloading the deployed files to check they are correctly named/formatted?

Hi @Rohaaa,

Your files don’t have the .html extension:

index.html has it, no other file has, thus it’s loading like that.

1 Like

Now I have changed the extension .html but error is same.

Hi @Rohaaa,

I’m not seeing the changes. Have you re-deployed after you changed the extension?

yeah i have reuploaded the zip file

In that case, I’m still not seeing the changes. Could you share the zip that you’re trying to upload? You can use some cloud storage to share the file.

Processing: New static website.zip…

Hi @Rohaaa,

Looks like you forgot to link?

i have deleted previous website and deployed fresh website with extension of .html now the scenario is home page and about us page is coming from from netlify other pages are coming from main wordpress website please help me. Thanks.

Are you using the same domain https://doctor1.netlify.app/ as before or a new domain?

https://doctor1.netlify.app same domain i am using

Then I see no difference. All pages show as text except the homepage.


this is the file i have uploaded as a zip

I can browse to the .html files, however it still registers as text

These are the headers:

$ curl -IL https://doctor1.netlify.app/client-testimonials.html
HTTP/2 200
cache-control: public, max-age=0, must-revalidate
content-length: 79670
content-type: text/plain; charset=UTF-8 
date: Mon, 11 Oct 2021 05:50:01 GMT
etag: "af27cdb3f37a18283baf515baa300382-ssl"
strict-transport-security: max-age=31536000; includeSubDomains; preload
x-nf-request-id: 01FHPYDBZXKQ6NFT05GPK6Y5Q1
age: 6
server: Netlify

Note the content-type is text/plain which is why it still renders as text, not HTML.

where i get this file content type: text/plan.
one question i hvae created zip file from wordpress every time i have to change manually these setting?

I don’t know why the files are getting exported from WordPress as text/plain files and not text/html files (with the exception of index.html.) Whatever plugin you are using to export from WordPress is doing this.

One thing to note is all the pages that render as text still contain the WordPress URL e.g.

<link rel="canonical" href="https://doctor1.inkliksites.com/about-us" />

The index.html on the other hand contains the Netlify URL e.g.

<link rel="canonical" href="https://doctor1.netlify.app/" />

I don’t believe this has any bearing on the display of the pages in the browser, but it suggests there is something not configured correctly in the WordPress plugin used to export the static files.

While I have long stopped using WordPress, I would expect any well-written, properly configured, plugin to export the static HTML files with .html extensions so that you don’t have to manually modify them as doing so defeats the purpose of using such a plugin in the first place.

I am using wp2static-addon-zip-1.0.1 for generate static downloaded from Wp2static website