Deployed site doesn't reflect the contents of the repo

After updating a page on my site and deploying it to my site I noticed that the site is still showing the previous version of the page. The deployment log shows no errors and one new file to upload, which is correct. If I look at the commit hash linked to the deployment, the file that’s feeding the page has correct contents. I tried re-running the deployment with clearing cache but that didn’t have any difference. If I preview the site locally, the changes on the page are shown as expected. Is there any way for me to find out what’s wrong?

@waldek Welcome to the Netlify community.

You may be seeing a local and/or VPN caching issue.

Have you tried visiting your site in a new private / incognito window?

Have you tried downloading your deploy to see what file is actually being served?

I have downloaded the deploy and the generated site reflects what’s visible in the browser, but not what’s in the repo. That would eliminate VPN/caching from the equation, right?

Hey @waldek,

Unfortunately, this is a bit of a problem we see when proxying to Netlify using Cloudflare. Strictly speaking, it’s not something we can support very well and we’ve seen it cause headache with our atomic deploys in the past. Please feel free to check out our Support Guide on the topic and, if possible, try removing the proxying – I’d be very surprised if this didn’t help out :+1:!

Thank you for your reply, @Pie. I wonder though if it’s indeed related to Cloudflare:

  1. the deployment contains a generated file that doesn’t match my repo
  2. when I’m accessing my site via, which is the URL linked to the deploy, it’s not routed through Cloudflare and the issue is still there


You’ll want to ensure that your builds are successful and doing what is expected with the resources you’re adding to Git. Make sure you’ve not locked your published deploy to a particular version, too!


The log doesn’t show any issues. It points to the correct commit which reflects my changes. Also, I don’t have locked any previous deploy.

I fixed it and it was totally my fault. Turns out, I had a post with the same slug that was overwriting a specific page. Netlify works like a charm. My bad. Sorry for the trouble and appreciate your help :heart:

It was always going to be something trivial, after I re-read your thorough first posts. They’re always the hardest to track down so :mage: top sleuthing, @waldek! Glad you found it!

1 Like