Deploy fails because of incompatible module

Hi there! I’m a junior developer, and I just lost my first programming job because of COVID-19. I got the job six months ago, so it’s been about six months since I updated my Netlify + Gatsby website.

I’m getting this error during deploy and having a hard time finding answers via Google: "The engine “node” is incompatible with this module. Expected version “>=10.13.0”

I updated my version of node globally on my laptop, and node -v in my local repository returns version 13.12.0. I also tried deleting my package-lock.json and reinstalling everything using yarn, but still no luck.

Here’s the link: Netlify App

Any pointers would be much appreciated. Thank you!

1 Like

hi kimee, welcome! Looking at your build log, I wonder if this is not so much a netlify issue but a gatsby one as the call to that package seems to come from that install.

Are you seeing the issue locally as well? That’s always the first thing to check. Even if you have updated node locally, we may be hanging on to an older version on our servers. I think i’d recommend you try clear cache and deploy.

This Common Issue contains a ton of useful debugging tips that might help.

if not, please do share your package.json as well when you post again.

Thank you so much for your help, perry!

I set a deployment environment variable in Netlify for NODE_VERSION to 12.16.2, and that resolved this!


Thanks - this helped me as well!

1 Like

I tried setting my node version using a deployment environment variable in netlify (NODE_VERSION) but it would not work.

after a bit of looking around i found that my node version was being set via the netlify.toml file which is used for gatsby. I set my version in the netlify.toml file and my build version started using the correct node version.

1 Like

Thanks for chiming in here, @ali7566! Glad you found a solution :netliconfetti: