Deploy Fail help please

I need advice to debug deploy https://app.netlify.com/sites/angry-dubinsky-d389dc/deploys/5f8f23033a0615182a482b2b

hey there:


10:50:22 AM: failed Building production JavaScript and CSS bundles - 0.175s
10:50:22 AM: error Generating JavaScript bundles failed
10:50:22 AM: Cannot read property 'includes' of undefined
10:50:22 AM: ​
10:50:22 AM: ┌─────────────────────────────┐
10:50:22 AM: │   "build.command" failed    │
10:50:22 AM: └─────────────────────────────┘
10:50:22 AM: ​
10:50:22 AM:   Error message
10:50:22 AM:   Command failed with exit code 1: gatsby build
10:50:22 AM: ​
10:50:22 AM:   Error location
10:50:22 AM:   In Build command from Netlify app:
10:50:22 AM:   gatsby build
10:50:22 AM: ​
10:50:22 AM:   Resolved config
10:50:22 AM:   build:
10:50:22 AM:     command: gatsby build
10:50:22 AM:     commandOrigin: ui
10:50:22 AM:     publish: /opt/build/repo/src
10:50:22 AM: Caching artifacts

this is definitely the cause of the problem - something you are trying to include does not exist. Does this work locally? If yes,

Here is some general debugging advice:

If no, you’ll have to fix the issue locally first before trying to deploy, as its not a netlify problem in that case.

Thank you for responding! I am a baby dev, I am about to graduate from a crash course at my University, so I am not suuuuuper familiar with Netlify. Yes, everything works just fine with local host. I cannot find the error- it said “includes” is undefined, but I have no idea where that error is located. I am MothershipWit on Github if you are interested in viewing the source code for finalproject…
I will read over the documentation you have provided! Thanks again

Your code does not “Build” locally. It is not a Netlify problem :slight_smile: It returns

`failed Building production JavaScript and CSS bundles - 0.168s

ERROR #98123 WEBPACK

Generating JavaScript bundles failed

Cannot read property ‘includes’ of undefined`