Default dns don't work but custom works

If we set netlify’s ns records as our domain’s ns records and use the default netlify DNS records which are added automatically after adding the domain to netlify, earlier that way worked. But recently for my .tech domain that doesn’t work. Instead after I removed those netlify records and added the following records on netlify’s DNS panel then the both domain shows netlify DNS. Now my question is why? I have used and namecheap before and I don’t have to change this records for them.

Hi @Nirzak,

Thanks for reaching out!

I see that the NETLIFY records for and have been deleted in the DNS Zone (Netlify App). The quickest and easiest way to add them back is to remove the custom domains from here (Netlify App) and then add the domain back.

The Netlify Records should then be recreated.

Note that since you’re using Netlify DNS, the only change you have to make is at your registrar to change the name servers to the Netlify name servers mentioned here.

Yeah later I deleted those records and then again tried to use the NETLIFY DNS records by removing and assingnung the domain. And then it works. But I was just thinking why was it not working in the last night but worked for the above records after I changed it. It’s not about the propagation. because if this was an issue of propagation then those apex load balancer DNS record also shouldn’t work. Isn’t it?

Duplicate: Problem delegating dottech domain name - Support - Netlify Support Forums