Debugging Jekyll Deployment

I need advice to debug deploy Netlify App

Hi @rcohan08 :wave:

I’m sure I and others in the community would be happy to help get you pointed in the right direction.

Could you clarify the specific deployment issue you’re experiencing? Any and all specific errors, questions, logs, or odd behavior you’re encountering would be extremely helpful.

I’d also recommend reviewing the “Asking Great Questions to get Great Answers” post from the Support forum at the link below:

It’ll help us all help you. :bowing_man:

2 Likes

Hey @birdcar, you’re not able to see the logs in the link in my original post?

hey there @rcohan08 - i can see your build log! it looks…long!

I did spot this error which is likely the beginning of your problems:

10:10:51 PM: [4/4] Building fresh packages...
10:12:39 PM: error /opt/build/repo/node_modules/node-sass: Command failed.
10:12:39 PM: Exit code: 1
10:12:39 PM: Command: node scripts/build.js
10:12:39 PM: Arguments:
10:12:39 PM: Directory: /opt/build/repo/node_modules/node-sass

something is broken with node-sass, i believe.

question: are you able to get this to work locally? :thinking:

Hey @perry it builds and runs flawlessly locally using gulp.

Hey there, @rcohan08

Thanks for following up, and welcome to the Netlify Forums :netliconfetti: ! Sorry to hear you are having difficulties with your Jekyll site.

First, have you seen this blog post for using Jekyll 4.0 on Netlify? This walks through the basic steps of getting your Jekyll site up and running, starting at the Installing Jekyll phase.

Once you double check that you have taken the appropriate steps, please walk through our available debugging site builds resources.

Lastly, please search in the Forums for related Jekyll build threads. I think you will finds threads like this: Jekyll Build Issues on Netlify but not local or Github Pages to be related and beneficial. There are also threads related to node-sass, as @Perry pointed out that there may be an issue there. This one looks like it could be a good place to start: Netlify not Building. "build.command" failed - what to do? - #3 by luke

After that, if you are still having issues, please come back and share:

  1. Your Netlify site name
  2. Your repo, if public
  3. The steps you took to debug this
  4. A question you are hoping we can answer