Home
Support Forums

Debugging Deploy- My Gitsite is having issues updating the new files

I need advice to debug deploy Netlify App

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

Yes of course, The error that keeps recurring is below. I have tried adding the netlify.toml file with the plugins installation. Code: [[plugins]]
package = "netlify-plugin-image–optim’
11:27:58 AM: Build ready to start

11:28:00 AM: build-image version: 653805ca4a64301556e56dc4b321ef8fc20cbb7c

11:28:00 AM: build-image tag: v3.8.2

11:28:00 AM: buildbot version: 5ca46ad10ed1b3bf6d683d62872e59029498e5a4

11:28:00 AM: Building without cache

11:28:00 AM: Starting to prepare the repo for build

11:28:00 AM: No cached dependencies found. Cloning fresh repo

11:28:00 AM: git clone GitHub - Esalguero007/UI

11:28:02 AM: Preparing Git Reference refs/heads/master

11:28:03 AM: Parsing package.json dependencies

11:28:03 AM: Creating deploy upload records

11:28:03 AM: Failing build: Failed to parse configuration

11:28:03 AM: Failed during stage ‘Reading and parsing configuration files’:
When resolving config file /opt/build/repo/netlify.toml:
Could not parse configuration file
Expected “”", “\U”, “\”", “\\”, “\b”, “\f”, “\n”, “\r”, “\t”, “\u” or any character but end of input found.

: exit status 1

11:28:03 AM: Finished processing build request in 3.407258955s

But maybe I’m missing the package.json file.

Can someone help with this issue, I’ve read over the articles followed the similar steps noted for similar problems. And I’m still experiencing issues.

As mentioned in the other (now closed) thread you started, you Git repo is plain HTML, CSS, and JS, so there is nothing that requires building—ie. no need for a build command such as npm run build.

I had to fix the errors, but now it’s functioning properly, thank you kindly.