DatoCMS authorization with Netlify - ERROR During Authorization


I am attempting to build a site using GatsbyJS, DatoCMS, and Netlify.

While attempting to add a Netlify build method to DatoCMS, I am running into an error when I try and authorize my netlify account with datoCMS. Is this issue related to Netlify?\

For reference, what I am trying to do is listed under Step 3 on this website – > https://www.datocms.com/docs/deployments/netlify/

1 Like

Hello, Matteo from DatoCMS here.

I can confirm the problem and we are not getting any information back.

The page shared in the screenshot above returns a 500 error and we don’t get anything back.

Can you please help tracking down the issue? Thank you!

I’m very new to this, so I’m not sure how much help I would be! I’ve tried everything I can think of, from renaming environment variables, to rebuilding gatsby to no avail. Do you have any recommendations of what I could do/where I could look to solve this?

EDIT: The issue I was having before this started was a 401 INVALID_SITE error, stemming from not having the DATO_API_TOKEN entered into Netlify correctly. This error came directly afterwards… maybe I did something incorrectly previous to this, that is causing the holdup?

Hi, sorry about this issue!
Can you please try this again? It should be working again now, there was a bad configuration change rolled out and we have since fixed it.

1 Like

It’s working now! Thank you so much!

1 Like

I can confirm it’s working fine. Thank you vey much!

1 Like