Custom site not redirecting to https

my site is not redirecting to https. Don’t know why. Everything seems setup correctly. Please check.

Update - just after I posted this I tried it again and now it is redirecting properly. It seems to be hit and miss. Works some times and not others. What could cause that?

When I tried it an hour ago it showed my registrar’s site page.

@play4sale http redirects to https for me.

Is it still behaving inconsistently for you?

Yes, really strange. This morning it wasn’t, then a couple of minutes later it was. Same thing now. 5 minutes ago not working, works now though.

It’s hanging right now, just after I tried an algolia search. It hung up my phone for the site also. Again, after about a minute, it works again.

I don’t see any issues with or not redirecting to @play4sale.

@play4sale Do you think you might be having general internet connectivity issues?

Maybe, but how do you explain my phone also having the same problem? A couple of times I’ve tried to renew the Let’s Encrypt certificate and nothing happens, the date stays the same. Maybe that’s how it’s supposed to work, I don’t know. My Netlify sub-domain for this site has not had this problem so I’m thinking it’s certificate related. We’ll see what happens in the next few days.

Update - here are 2 screenshots showing the problem.

According to this article it is a Firefox-only issue. Nothing to do with the SSL certificate itself. It is a local issue.

FWIW, I tested using Firefox and did not receive the error.

Hi @play4sale,

I’m unable to replicate the issue as well. The site loads properly with SSL. I’ve also tried Firefox and it also loads correctly. I also see that you’re using Netlify DNS and Netlify’s name servers are correctly configured:

dig NS +trace | tail -n 6		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS
;; Received 125 bytes from in 8 ms