Custom_domain is owned by the other account

Hello

I recently needed to move a custom domain and build from one account to another. I deleted the custom domain on the original account and then recreated the build on the new account. When I try to add the domain I get this error:

custom_domain is owned by the other account

Not sure what I can do…

1 Like

I ended up figuring out what was up. You have to delete the DNS Zone, then delete the custom domain to release it to the universe

1 Like

thanks for sharing your solution! That is what we would have advised :smiley:

@labboy0276 I tried to delete the DNS Zone on the former account, but I didn’t find it. When I deleted the site from the former account, I thought that the custom domain was deleted too… The domain is remediar.ong.br.

Steps

  1. I opened https://app.netlify.com/sites/remediar/settings/domain
  2. At “Custom domains”, I click “Add custom domain”
  3. At " Add a custom domain to your site", I type remediar.ong.br and click on “Verify”
  4. I saw the message “remediar.ong.br already has an owner. Is it you?”
  5. I click “Yes, add domain”
  6. Then I see the following message:

custom_domain is owned by another account

Hey @jimmyandrade, I’m not seeing a record of that domain in our database. Can you tell me the previous site or account you tried to delete it from?

Ah, I think we know what happened here: someone mistakenly added ong.br to their Netlify DNS setup, which blocked anyone else from using that TLD, even if you do own a domain like remediar.ong.br. We removed that from the other account, so you should be able to add your custom domain here:
https://app.netlify.com/sites/remediar/settings/domain#custom-domains

Please do not enable Netlify DNS with this domain or you will create the same issue you just ran into for someone else :slight_smile:

Let us know if things work as expected for you now or if we can help with anything else!

1 Like

Thank you so much @jen, now it works.

1 Like

@jen I’m having the same issue. I have access to the DNS manager via AWS Route53 for 'civicdatadesignlab.mit.edu` but I’m receiving the same error message:

Hey @innoobijr, sorry to hear that you’re running into this! I took a look and it seems like someone set up a Netlify DNS zone for mit.edu, which we should not have allowed to happen.

I’ve deleted that zone so you should be able to set up your custom domain now. When configuring, please do not select “Set up Netlify DNS”- you’ll want to continue using AWS Route53 as your DNS host and then point to our servers from there. Here are more instructions if you need:

Please let us know if this continues to give you problems or if you have other questions down the road.

Hi Jen,

Could you check this other thread:

Seems to be the same issue or very close to it.

Looks different to me, though obviously same error message. DNS is a real pile of :spaghetti: I responded over there :+1:

@jen Thank you! thank you!

1 Like

Hi @jen , I have the same issue, my domain is bestintheworld.tech Could you please help me?

Hey @RicardoennetlifyC, looks like that domain was used on your previous team, which you’ve deleted. But the DNS zone didn’t get deleted with the account, so I’ve gone ahead and done that now. You should be able to use it on your new team + site- please let me know if that’s not the case!

1 Like

hi @jen I’m facing the same issue with blog.domainname.com verification. The CNAME record in DNS settings is correct, it is pointing from blog to the netlify’s app name. Using dig -t CNAME I can see that it has been set correctly. What can be wrong with my settings?

Everythings works now perfectly, thank you, thank you!

Greetings from Mexico. @jen.

Hi, @nik, in order for us to troubleshoot we need to know the domain name which isn’t working. Would you be willing to please share that with us?

You can private message (PM) that to one of our support staff and I’ve confirmed that PMs are enabled for your community login. Note, that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

1 Like

Hi, @nik. I received the PM with the details about the custom domain. I did find that domain configured on an already delete account (which deletes the account but not the DNS zone configuration for reasons I won’t detail).

However, it was a deleted account and the DNS zone was inactive and, for these reasons, I’ve deleted the zone now. This means that you should be able to add this domain to your new site/team now.

If this still doesn’t work for any reason (or if there are any questions), please reply anytime.

1 Like

Hi @jen I have the similar issue connecting my domain amu.org.rw .
I have got this error name amu.org.rw is conflicting the ownership with other existing zones.

thanks

Hey @iraguhalionel, I’m sorry to say that I can’t find a record of this domain in our database. When I go to that URL in the browser, it shows Server: Apache in the headers, which means it is not served by us (sites that are served by us say Server: Netlify).