Home
Support Forums

Custom domain - A DNS zone already exists on NS1

Hi, @mjsorribas. The error means a DNS zone already exists at NS1 and because of this we cannot create one ourselves. Many other services use NS1 -for example, last I checked Squarespace used them as well.

The error doesn’t tell us what other account created the DNS zone at NS1. You will need to look for places you entered this domain with other services and remove it there. Similarly, you might try contacting NS1 directly to ask them what account created the DNS zone.

In the meantime, you can also use the external DNS instructions above to connect the domain to Netlify. This doesn’t rely on NS1 and can be used while you work on resolving that issue.

If there are other questions, please let us know.

Hi @perry I am going through this same process (domain already purchased from Name.com), and I am stuck because I still cannot get the automatic SSL/TLS certificate with Let’s Encrypt with Netlify. Could it be because the only difference is that Name.com documentation specifies one more step: Adding a new Nameserver? Or this step it is not necessary?

Hi,
Everything is working now, got the SSL/TLS certificate finally. My two cents on the case of a domain already purchased from Name.com and the process to use it with Netlify:

  • Netlify’s doc site has everything to set the process (custom domains - DNS zone already exists on NS1). But I also needed the how-to and I found it here in the forum;
  • I followed all the steps @perry explained (kudos to him!), and, as specified I had to contact the Name.com support team for this issue. They answered fast, deleting the zone on the backend. So keep in mind that this is a step to cover for this process;
  • Regarding Netlify’s nameservers, I don’t understand why that step is not covered before (Delete all previous nameserves and just right after adding the ones pointing to Netlify);
  • In any case, once you add the new Netlify’s nameservers the process is smooth and fast.

Good luck!

1 Like

@luke I am experiencing the same issue atm and I couldn’t resolve it via support ticket. I’d be really happy if you could remove the “phantom” DNS zone for me please.

Hi, @domainexpert-xyz. I can check to see if this is the same issue or not … once you tell us the domain name. :wink:

You can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

Looks like we’re all after you, but we have no other option. I have also done all the previous steps and I think the problem is the same like for the rest of you. My domain name is barneysbrunch.house. Could you please remove the phantom dns zone for my domain so I could finally fix this issue?

Just in case it helps others. What I did wrong was that I put Netlify dns to my domain without setting it up first, I just used the NS from another website that I had connected successfully with Netlify. That’s why Netlify registered my domain, but with the wrong NS records that I provided. So, when I tried to claim my domain and get the real NS records from Netlify, it was giving the error “A DNS zone for this domain already exists on NS1”.

Hi, @arlindmusliu. I’ve checked our NS1 account and there is no DNS zone for barneysbrunch.house under our account at NS1. Some other company must have created.

In almost all cases, if you contact NS1’s technical support about it they can quickly resolve the issue.

It was fine to check with us first and we would be able to assist if it was our zone. However, we didn’t make the zone in questions so we cannot delete it.

If there are other questions, please let us know.

1 Like

YES, FINALLY it WORKS!!! So, just in case someone else has this problem: When I contacted NS1, I got this automatic reply:

Unfortunately, we do not have your email address associated to any username / account within the NS1 Portal.To verify your account, can you either write in using your registered email address or contact your Account admin to update your profile to use this email address.

Then, I contacted them again to understand where’s the problem because Namecheap has deleted everything, Netlify doesn’t have anything on their end, so it’s only NS1. Then, I got this answer:

We found that the domain had been automatically detected as being delegated to NS1’s nameservers but it did not exist in any account, so as a safety measure our systems added it to our parking account. This is an automatic measure to keep domains safe.

We have now deleted the ‘barneysbrunch.house’ domain from our parking account, so you should be able to add it to Netlify.

With regards to your e-mail address being invalid, it’s because it isn’t assigned to any customer we have, though in your case this is fine as we are able to remove the domain so solve your problem.

So, this was my problem, and it’s finally solved.

Hi, @arlindmusliu. Thanks you following up to let us know how you resolved the issue. :+1:

Hi @luke, I’m having the same issue with https://www.sagexperiences.com which was bought on https://www.bluehost.com/

I have contacted ns1 as well and their team has mentioned the following, “While your domain is currently delegated to our name servers, your account appears to be managed through Netlify.”

Unfortunately, I do not have any domains managed by Netlify now, so I am hoping that there may be another ‘phantom zone’?

Hi, @seancze. It was as you suspected - a ’ phantom zone’. I’ve deleted it and you will be able to a the domain to your Netlify team now.

If it still gives errors or if there are any questions, please let us know.

1 Like

Hi, @nialna. I’ll replied over on your follow-up post here:

In the future, please do not make more than one post for a single issue. Doing this only slows us down.

Hi! can you please remove my previous DNS zones for this domain. Previously, I had added a netlify hosted site on this domain which I deleted later on. Now when I try to configure this domain to my netlify account, it’s showing this error.

Hi @hamzahmd,

I’ve replied to your thread. Short note, that DNS zone doesn’t exist on Netlify.

Hi @luke , having the same issue with this error for the domain http://www.conversationswithashipwreck.com bought on Namecheap. I was able to manually configure it, but would like to configure it with Netlify’s Managed DNS. Is there a ‘phantom zone’ issue occuring?

Hi, @seventhofseven. I checked and I can confirm that, no, there is no phantom DNS zone issue occurring.

The recommended solution is to delete any DNS zones for this domain you may have configured with other services. Alternatively, you can create an account at NS1 (which is free - there is no charge to do so) and then ask the NS1 technical support to delete the DNS zone there for you.

If there are other questions, please let us know.