Home
Support Forums

CSS not loading on site deployed to Netlify

I’m running into a problem - no formatting/css on the deployed Netlify site. I checked the config.toml and have a slash at the end of the baseURL (I also tried www subdomain with slash at end). I checked blogdown::check_site() and there are no to-dos. I am using Hugo in R with the blogdown package.

Netlify site: https://oliverstringham.com/
GitHub repo: GitHub - ocstringham/oliverstringham: Personal website of Oliver Stringham

I think it could it have to do with where the domains are registered. I have a google domain name that I just set up for Netlify. Here is what the Google Domain set up looks like:

Host name Type TTL Data
oliverstringham.com A 1 hour 75.2.60.5
www.oliverstringham.com CNAME 1 hour oliverstringham.netlify.app.

Also, I inspected the page code and it looks like the CSS style sheet is being blocked for some reason. It gives this error: Subresource Integrity: The resource 'https://d33wubrfki0l68.cloudfront.net/css/c52bea5ca2445229a792f42487a85692f6bee107/style.main.min.73e736bd4383f8090e0c7bb46d2b9fe5208816195891be73629cff4d163878c9.css' has an integrity attribute, but the resource requires the request to be CORS enabled to check the integrity, and it is not. The resource has been blocked because the integrity cannot be enforced.

To fix that, I tried to add crossorigin="anonymous" to the link css tag (as suggested here), but that didn’t work.

Hi @ocstringham,

Would you try disabling asset optimisation for your website?

Yes, how do I do that? Thanks

From here: Netlify App.

After doing it, it should look like this:

Yes, I disabled the CSS optimizations (“Bundle CSS” and “Minify CSS”). After a new deploy the CSS now loads on the website!