Home
Support Forums

Creat React App not Deploying to Netlify

Please the image above is what I keep getting when I deploy my react app to netlify

Here is the repo link https://github.com/femakin/Windbnb-Challenge

That’s strange. I just cloned your repo and tried to deploy it and got no such error.

Would you retry by deleting all the lock files to see if it makes a difference?

Please I need help @hrishikesh I tried it again but was still having the same issue. I deleted all the lock files and it’s still the same. You can verify this by checking the repo. PLEASE HELP ME OUT

I don’t think I’ve an explanation for this. I retried and it still deploys fine for me. I can see you have had this issue with another one of your websites too in the past. But that works fine now, I suppose.

What you can do is, try doing a manual deployment and once the website is created, connect your Git repo to it.

Hi @femitosin,

I too was able to clone and deploy your repo.

It did seem to hang the first time (though no error like you had), so I cancelled it, then under Trigger deploy selected Clear cache and deploy site.

1 Like

I deployed but the page was page not found

You’ve not set build as your publish directory:

1 Like

Thank you @hrishikesh It worked now… Cc @coelmay

2 Likes