Could you activate the https on my staging domain?

Could you activate the https on my staging domain. The domain is: Thanks.

Hi there,

I did some digging and I can see the domain with a SSL cert. The ‘’ domain isn’t in use at Netlify.

If you’re still encountering a problem, can you elaborate a little further, please? Thanks!

Thanks - I’ve added the domain onto Netlify now. Could you activate the https on it?

I’m following the information on this page - just trying to get my staging branch setup:


I can see that the domain was added and, almost as if by magic, the certificate has renewed to cover this subdomain!

You can view this yourself by going to your team, selecting the site and navigating to Settings > Domain management > HTTPS :slight_smile:

I do love magic, thanks :slight_smile:

So, I’ve added the staging to the DNS as explained:


And I can see that “staging” is being deployed in Netlify.

But the branch is not showing on my staging domain. I’ve checked the DNS using nslookup and all looks okay. Just wondered if I’m missing another setting somewhere?

Hi, @creativefire, there is a manual step needed on our side before the SSL certificate will cover the branch subdomain.

Also, the branch subdomain must match the named described in that common issue topic. The subdomain must be the branch name plus a dot plus the primary custom domain.

Because the primary domain is the record should be:

and not:

Would you please make that change and let us know when that is done? Once that is changed, we’ll be happy to extend the SSL certificate to cover that branch subdomain.

Note, you should also remove any branch subdomains from the custom domains list for the site as this will cause that subdomain to show the production branch, not the branch being configured.

Please let us know when the change has been made and/or if there are any questions.