"Could not provision certificate" error with registered custom domain


Last week I deployed my site on Netlify, and started configuring my custom domain to lead to the one I registered externally. The Netlify site name is nifty-jones-940ad1.netlify.app and the custom domain is http://www.lodybo.nl/. This works and I can access the domain, but the provisioning of a certificate failed. I’ve read multiple support tickets and guides but still haven’t resolved the issue. I’ve not enabled Netlify DNS but I have configured the following in my DNS host:

  • CNAME value for www is set to nifty-jones-940ad1.netlify.app
  • A record for the apex domain is set to Netlify’s laod balancer:

I can verify those settings in dig, but I’m still getting the “We could not provision a Let’s Encrypt certificate for your custom domain.” error in my Dashboard.

Could you tell me what steps I can follow to fix this?

Hi, @Lodybo. There is a AAAA record pointing an IP address not at Netlify:

$ dig lodybo.nl AAAA  +noall +answer

; <<>> DiG 9.10.6 <<>> lodybo.nl AAAA +noall +answer
;; global options: +cmd
lodybo.nl.		3600	IN	AAAA	2a00:f10:305:0:1c00:dfff:fe00:4be

Once you delete that record, wait one hour (because the time to live (TTL) value is 3600 seconds).

After the hour is up, the record will have expired from any DNS caches and the SSL provisioning should completely successfully at that time.

If this doesn’t resolve the issue or if there are any other questions, please let us know.

Hi Luke,

Thanks, I started to have some doubts about the AAAA record. I removed it this morning (approx. 2 hours ago) but the provisioning still fails with the same message.

If I run the same command in dig as you do, the only returned record is the A record pointing to your load balancer.

Thanks in advance.

Nevermind my previous comment. I refreshed the page on my domain settings and SSL provisioning had succeeded. Maybe I missed refreshing page before I clicked the button or something, I don’t really know.

But it works now, thanks a lot! :slight_smile: