CORS error in UI preventing Netlify Managed DNS record changes

I am unable to delete or create a new Netlify Managed DNS record. I tried using 2 different computers and upon checking the browser console I saw a CORS error which is preventing the UI from doing the actions I am requesting on “”. I have put the error at the bottom. I cleared my browser cache and that didn’t help. I also checked and Netlify don’t have any reported outages or errors at the time I am submitting this.
Thanks for your help!

Access to fetch at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

Update: I tried disabling CORS in Chrome just to update this records so I can get back to my project but now I am getting the status 502 Bad Gateway returned from Netlify.

Update: I am now getting HTTP error 442 when creating a record and the returned HTTP body is {"errors":{"dns_api":[" - 521 - "]}} and despite returning 204 No Content when deleting a record after a page reload the record still exists.

It seems to be back to normal. Hopefully some tests can be put into place to prevent this happening again! :laughing:

1 Like