Continues deployment problem for repo

hi, there.

I have deployed a site using netlify api

 var settings = {
    url: "",
    method: "POST",
    timeout: 0,
    headers: {
      Authorization: "Bearer " + token,
      "Content-Type": "application/json",
    data: JSON.stringify({
      name: sitename,

      repo: {
        provider: "github",
        id: GitRepoID,
        repo: USRNAME/REPO,
        private: true,
        branch: "master",
        deploy_key_id: deploy_key_idd,

The deployment has successful and the site is live.

Now when I update files in GitHub using GitHub API , the files in the GitHub is updating.

But the site is now not deploying with the updated files from GitHub

Note: Auto publishing (continues deployment) are enabled in netlify

Hoping with a positive response.

Regards, shiva :wave:

Hi, @shiva. If you tell us the site API ID (or site subdomain), we can look at the repo object in the database and tell you if what we find matches what is required.

It might also help to query the API to compare the responses for a working site repo and a non-working site repo. This might help you find the issue without our support team looking up the object in the database. (In other words, by querying the API you can get the same information I will be getting but without needing to wait for me to answer.)

I am happy to find this as well. I’m only sharing other options so you won’t have to wait.

​Please let us know if there are other questions or which site the repo doesn’t work for (the site subdomain or API ID).

@luke , sorry for the late response,

my app API id is 25055dc8-2ed7-4566-8241-d9a14cc0d23c , please have a look.

Regards, @shiva


Could you please help us with this issue

hi surya, which issue? are you working together with shiva?

Hi, @Surya and @shiva. The repo in question is missing the installation_id mentioned in this support guide:

I see the same above. The example code does not include the required installation_id key and value.

The installation_id is the id for the Netlify GitHub app. You can get the id from the GitHub here:

If you have a single user team, the id can be found here:

Click on the Netlify app or copy the URL. The id will be at the end like so:
  • where 12345 will be some other number which is the real installation_id

You can also query GitHub’s API to get that information.

If there are other questions about this, please let us know.

@luke ,

Sorry I haven’t understood the answer.

Can you please explain it another way

Regards, shiva

hi Shiva - please try working through the steps above as luke has explained! we’re unable to really assist beyond this point, i am afraid.


Amazing that worked for me manually

but how can i get that netlify github app installation id using any api
like github api or netlify api for a any user account

Regards @Surya

Hi, @Surya. That information comes from GitHub’s API not ours (the GitHub app installation id).

We have a support guide about reverse engineering our APIs (or anyone else’s) here:

To summarize, open devtools and make the change in the UI. In this case, link a new repo. You will see the API call being made to github in the Network tab. To find it, I like to filter the network tab for the domain name or even the string “api”.

This is the result of the “copy as curl” data for the github API call:

curl '' \
 -H 'User-Agent: <REDACTED>' \
 -H 'Accept: application/vnd.github.machine-man-preview+json' \
 -H 'Accept-Language: en-US,en;q=0.5' --compressed \
 -H 'Referer:' -H 'Content-Type: application/json' \
 -H 'Authorization: token <REDACTED>' -H 'Origin:' \
 -H 'Connection: keep-alive' -H 'Pragma: no-cache' \
 -H 'Cache-Control: no-cache' -H 'TE: Trailers'`

If there are other questions, please let us know.

1 Like

@luke ,

Thanks for your response.

But when i request using the below url

I get the installation info of my GitHub App only, but I need to get the installation info of your GitHub App (Netlify).

Hope you understood the point and Hoping with a positive response.

Regards, @shiva

hi Shiva, I’m sorry, but i still don’t understand exactly what you you need or you are trying to do. Have you tried getting some assistance from the people at GitHub?