Content updates (made through CMS or Github) not shown on website

Hello! I’m using the Hugo/Academic template together with Netlify CMS, and GitHub hosting. I tried to update the contents of my website using first the CMS itself, then by editing GitHub files directly, according to the Academic documentation. Both attempts have failed:

Namely, if I edit the content of the various .md files, such as /content/home/, these edits are not shown in the website, when I open it in a browser (even after I wait a while), even if the commit itself (done on the main branch) is successful, i.e. edits to the file itself are saved.

On the other hand, I cannot anywhere in my github repository find text contained in the default contents of these widgets, so clearly I was not updating content in the right place.

I also tried to get NetlifyCMS to let me edit all of the various widgets using its GUI. Right now the only β€œCollections” I see in the CMS are the default ones in Academic: Authors, Posts,etc. If I edit content from there, the changes are seen on the website, so I tried to add there other widgets from the Academic template (Experience, etc). However, I found no place in the site’s source code (or in the very austere Netlify CMS interface) where to edit that list of widgets.

Can anyone help? THanks! :slight_smile:

Hey @tudorpopescu,
Any chance you could share your repo with us so we can see how it’s set up? At the very least, please send your config.yml for the CMS and your Netlify site name :slight_smile: Thanks!

Thanks Jen for your help, and sorry for the late reply. My repo is here and my netlify site name is: tudorpopescu. Please let me know if you are able to have a look or if I should send anything else.


I was able to look at one of your deploy logs and found this error:

8:08:10 AM: Building sites … Total in 104 ms
8:08:10 AM: Error: Error building site: "/opt/build/repo/content/home/": unmarshal failed: Near line 36 (last key parsed 'experience.Institute'): expected key separator '=', but got 'o' instead
8:08:10 AM: ​
8:08:10 AM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
8:08:10 AM: β”‚   "build.command" failed    β”‚
8:08:10 AM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
8:08:10 AM: ​
8:08:10 AM:   Error message
8:08:10 AM:   Command failed with exit code 255: hugo --gc --minify -b $URL
8:08:10 AM: ​

Something in that file is making the parser very unhappy. What do you think? :thinking:

Wow, really not sure what to say. β€œExperience” was just the name of the widget that I was trying to edit, but I’ve no idea about the syntax error that you saw. Is there a way to get round it? Also, I never did actually find a way to edit those Widgets, and support from Hugo/Academic seems unresponsive.

Hey @tudorpopescu,
I believe the error that @perry mentions happened here:

After date_end you’ll need a description section that looks like:

description = """
Institute of Art and Musicology- Dresden Music Cognition Lab. 

Let us know if that helps!

1 Like

Thank you Jen! I fixed that syntax error and committed the change, however the Experience widget still shows content from the generic template, such as the text β€œTaught electronic engineering and researched semiconductor physics.”. I cannot find where in my github files this text resides, so I can replace with my own!

Furthermore, while the Experience and Projects widget are all visible as you scroll down the main page at, the site’s top header contains a section (Posts) that is not in that list. I found an entry for this in /config/_default/menus.toml, however after editing that section name to something else and committing, still the changes do not appear on the live site. Thus, what I am editing here appears to be always different from the files that the site actually gets its contents from.

This combination of Hugo/Academic and GitHub appears very cumbersome, so let me shift gears and ask: what other website solution can I use to make this process simpler?
All I want here is a basic personal website with text and a few pictures&links, which I’d have thought could just be done in a WYSIWYG interface, that allows direct editing of the text as it appears on the site. How could I achieve this?

Many thanks!

hi there,

i can’t answer the first question for you but i can help you with the second! For a simple site, i really recommend stackbit. It’s a free service that deploys to netlify and allows you to pick a CMS, (i recommend Netlify CMS, but there are also others to choose from), and a static site generator. You can also pick a theme. Once you have made your choices, it deploys to netlify and you have a fully working site. Check it out and see how it goes! I use stackbit for one of my sites and i like it a lot.