Support Forums

CMS password reset does not work in Chrome

Hello, recently password reset links have stopped working on Google Chrome web browser where it has previously worked without issue. I was able to get it to work using both Firefox and Edge browsers.

The site uses Netlify Identity, Git Gateway with Gitlab and a private repo and accounts are invite only.

These are the steps I took:

  1. Click sent reset password on this page: Netlify App
  2. I receive the email within a few minutes and click ‘Reset password’
  3. The page that opens redirects to the home page with ‘/#’ at the end and this console error: netlify-identity.js:3322 POST https://SITE-NAME/.netlify/identity/verify 404
  4. The network tab in the Chrome inspector has this response from the above endpoint: {"code":404,"msg":"User not found"}

I have tested this in Chrome with my usual extensions and with all extensions disabled and using a separate laptop and still had the same result. Also, when I create a new user and try to use and invite email, the same issue occurs.

When I follow the above steps in Firefox, I am presented with the ‘Recover Password’ modal on my website and the network tab has a response from the .netlify/identity/verify of an object with keys: access_token, token_type, expires_in and refresh_token. Inviting users also works correctly in Firefox.

Is there a way that I can get this to work in Chrome as it has in the past? Many thanks!

Chrome 80.0.3987.163 (Official Build) (64-bit)
Firefox 74.0.1 (64-bit)
“netlify-cms-app”: “^2.11.26”
“gatsby”: “^2.19.23”
“gatsby-plugin-netlify-cms”: “^4.1.40”

hi there, just to rule this out - are you running any browser extensions that might be interfering? one easy way to test that is to try from an incognito window.

Hi Perry, I have tested this with my usual extension and with all extensions disabled as well as in incognito mode and I get the same results. In the past, this worked with all my extensions enabled anyway.

My client is also unable to get this to work in Chrome and has informed me that it also doesn’t work in Safari, however I haven’t tested this myself yet.

I have now tested this in Safari and the behaviour is the same as in Chrome i.e. the reset password modal does not appear and the I receive a 404 console error

Edit 2:
I was able to fix this issue; it turns there was a problem with my gatsby-config.js file but no error was showing on build. Not sure why it only broke in certain browsers but it seems to be working now.

1 Like

fantastic. so glad it is working, and thanks for keeping us updated! :tada:

hey, I got same error, how did you fix it? thanks.