CI=false not working for one particular project

So when using create-react-app to build my project, I use CI=false to stop warnings being treated as errors. However on this particular project it just doesn’t work for whatever, i’ve posted the log below.

Anyone got any idea why?

hi @NathanLeadill , this is an interesting one. Apparently, false is not the opposite of true necessarily in this case. See this doc:

does setting CI=' ' work as described in that doc? i’m very curious about this myself.

Just tried it to no avail, it’s a weird one, i’ve tried creating a whole new site to see if it was a configuration issue, still no luck.

The syntax is CI= npm run build.

I’ve tried this aswell, to no avail still not working!

That’s a little concerning. Mind sharing the repo?

It’s actually a work project so i’m prevented from sharing the repo, i’m happy to post any file you think necessary though.


Well, I’d need at least a minimal code that can reproduce this issue. I have just tried another build with the code I suggested above and it worked, so your case seems to be special and it might not be possible to guess randomly.

Can you email me and i can share the repo with you privately :slight_smile:

Sure, I’ve messaged you privately. Respond to that.

1 Like