Changing region and increasing timeout seconds for netlify functions

Hi @perry @verythorough yes, definitely background functions could be useful for us although it takes some time and effort to convert our logic (and client code) from a synchronous function to an asynchronous function.

Since we are hitting the time limit for our users in production we would need the time limit update for now.

We will definitely look into switching to background functions in the future.

1 Like

Hi, @avk. I’ve extended the functions timeout for that function to the current maximum of 26 seconds.

Please note, the function or functions for this site need to be redeployed for this change to take effect.

If there are other questions or concerns, please let us know.

1 Like

Hi!

Could the functions for the site below be moved to AWS eu-north-1 please?

Site: mjuk
API id: 79d5eafd-5cd1-45f8-8ddd-24084ffe6166

hi there! we took care of this for you - sorry it took us a while to get back to you.

if you make a small change (such as adding a console log) and redeploy, you should see the changes.

1 Like

Hey @perry

Please move these to: AWS eu-north-1

  • 10dad531-cbfa-45dc-a6ad-c23e48c30699
  • f0aa7168-be58-4434-912d-2451f9cf5212

Thanks.

hi @sissel, we’d be happy to, but both of those sites do not have Functions Level 1, which is a requirement to change the region. Once that is set up, do reply here and we can make the change.

Hey @Perry could we get some help upgrading the timeout to 26 seconds, cde40133-aed4-4601-9f4f-9f87a79eafa5 neo-edu. Thanks in advance

Hi, could you change our functions timeout to 26 sec?

App ID:

373743c1-ea79-4088-9749-1d9cf4a002d7
b8fbb791-4550-481c-abb7-52962aa2975d

The other asks (a bit related) is there is a way to run the --timeout with for netlify dev? I’m using netlify-lambda to serve the functions locally with desired timeout but would love for it to be ran with netlify dev

hey @cuongkoho, we bumped both of those sites up to 26 seconds for you. I don’t believe its possible to do what you are describing with netlify dev, but I am not an expert on dev. Let me know if that new timeout doesn’t work for some reason!

Hi we requested timeout increases for:

  • 6565f2c6-089d-4bcc-9c62-a16e1f62c55f
  • f7e5574e-b706-4bb7-a572-0ae799f31244
  • 58364616-001c-41a0-b288-5cad8a7e6152

These were actioned by support but in testing this morning the timeout is 10 seconds for all sites. Can you please inform us how and when they were reverted to the default timeout?

Can they also be increased back to the maximum available timeout?

Thanks Alex.

@AlexMeah, this is due to our Pro plan migration. Sorry about that. I have re-applied the settings for you. Also, don’t forget that since you have the Pro plan, you can always write into the helpdesk.

Thanks Dennis. Do you know roughly when this change (Pro plan migration) was made?

Hey @AlexMeah,

It would have been on your most recent billing day (which you can see on the billing pane in the UI)!

We’ve updraded to Functions Level 1 . Can we get the 26-sec timeout applied ?
site : awesome-shaw-81f33a
api : 5b39be0c-3197-435f-b477-6e7f409b0e2c

Thanks.

We’ve updraded to Functions Level 1 . Can we get the 26-sec timeout applied ?

  • 09b84bb8-d640-40cc-8f26-47da745d0f0f
  • a1d4b6e9-bff0-4036-8b83-64bf94de00c3

Thanks.

1 Like

Hey @iboum, sorted this in the Helpdesk with you! Cheers for reaching out :+1:

Hello @Pie,

Would you please up my timeout to 26 secs for this app:
f88acd47-7f30-460f-9d6d-2109f0f523dc

Thank you!

All done! Hope this helps.