CertOrder::CertAuthTickTimeoutError: Spent too long in ticking

Getting this error

CertOrder::CertAuthTickTimeoutError: Spent too long in ticking

We can’t renew your Let’s Encrypt certificate automatically until the issue is resolved. Check our troubleshooting guide for more information on how to fix the problem, and then renew the certificate.

The “renew certificate” button doesn’t seem to work

I also have this error for one of my sites. Did you find a fix?

Hey @andylobban - sorry to hear you are having trouble. We identified something that might be causing problems for @anthony a few days ago (can you let us know whether you are still seeing the same?), but i’m curious about you seeing this issue today. Did you try and push the renew cert button?

Hi @perry yes I pushed the new cert button a few days ago and also today, but still seeing the error.

OK. We are on it. I’ll update here once we have some news.

Hi @andylobban, sorry for the error message, also thanks for sharing the screenshot! That’s really helpful.
Seems like the certificate renewal itself actually went okay (you can see that “Expires” is in 3 months, and Let’s Encrypt’s issues the certificate with 3 months expiration), but some race condition left the error message hanging around.
We’ll look into more to avoid this from happening in the future, as well as improving “Renew certificate” button part too.


I am experiencing the same issue for my CNAME domain. Except my Cert will expire in a month.

I am also not seeing a renew cert button - where can I find it?

Thanks a bunch.

Hi @danielk, you may not see the renew button if we tried to renew the certificate less than 10 mins ago. Can you please check again and see if it’s still not there?

Thanks. Button is there. Certificate is renewed.