Home
Support Forums

Certificates update seems not to be deployed after using a custom one

Site name : whentocop

Hi,

We’re trying to setup external DNS management using Cloudflare for our domain name whentocop.fr

We initially tried to use the CDN (orange cloud) feature of cloudflare and setup Netlify to use a custom certificate.
We then read the Netlify doc and found out that the preferred way was to use the “CDN only” (grey cloud) of cloudflare, which we toggled on, and then switch back on Netlify to the auto managed “let’s encrypt certificates”.

Our DNS is now correctly handled by Cloudflare, “redirected” to Netlify, but the certificate returned is still the old custom one (marked as invalid because it is the Cloudflare Origin certificate, which should only be used for when Cloudflare proxies the content).

I tried renewing multiple time the certificate on Netlify but it has no effect.

Does anyone has an idea on how to force the automatic certificate to be used?

thanks

Hi @philippea,

I can see that the SSL certificate is configured correctly and the browser is loading the Lets Encrypt certificate:

Did something change by itself or are you still facing the issue?

Hi!

I reverted to using Netlify DNS ten minutes ago, it might be this ?
I’m still getting the certificate issue (I’m in France if it plays?)

Ok it’s back now, probably reverting to using netlify DNS management did the trick. So now I have to try again with Cloudflare ^^

If it doesn’t work or if you need additional help, let us know.

I’ve changed back to Cloudflare and it seems to work for now… some DNS magic !

Thanks for your help, will get back if needed