Home
Support Forums

Certificate issue adding custom donain

I am seeing certificate errors adding the following custom domain to site qn46;

https://api.deeptechjobs.com

I’ve sent a support request but didn’t receive any confirmation so opening this ticket.

How can I get the custom donain working on HTTPS?

Hi @mjgs,

You’ve another custom domain: deeptechjobs-dev.markjgsmith.com which is not correctly configured. Till you don’t configure it correctly, we can’t start provisioning the certificate. If you don’t want the domain, remove it from the UI and the certificate would be available for other domain.

Hi @hrishikesh - thanks fir the reply.

I removed that domain so the only custom domain on the site now is:

api.deeptechjobs.com

I verified the domain DNS configuration in the HTTPS settings:

#### DNS verification was successful

We’re ready to provision a TLS certificate from Let’s Encrypt and install it on our CDN.

And then re-provisioned the certificate in the https settings but got an error saying there was a problem issuing the certificate.

I tried again and got this error:

missing certificate

I tried a few more times and keep getting the missing certificate error. Quite a strange error IMO since I’m trying to create a certificate.

How do I generate the certificate?

I think it’s working now, the error was still in the UI for a bit, even after the domain started loading. It’s about 30 mins later now and the errors in the UI have disappeared.

Is that to be expected when creating a certificate?

Just a heads up, the provision certificate button is not meant to be spammed by retrying. It’s an automatic process and will happen eventually once you’ve made all the settings correctly.

DNS is tricky. If it’s working for you, doesn’t mean it working for everyone. The UI will show a green light only when it’s confident that it should be working everywhere.